1

Across the top of the panel, I have these status indicators: Language, Network Connection, Messaging, Volume, Time, and System.

Upon format and fresh install of 13.10, I see that Language icon does not change from white to dark grey when switching themes from Ambiance to Radiance. But whatever, I installed Unity Tweak Tool and a custom icon theme (Flattr) and window theme (Nitrux).

Now all my status indicators -except Time and Language- are stuck as grey, even though Niturx is a 'dark' theme. They are hardly visible.

And Language is still always stuck as white.

White .svg files exist for the indicator icons, and they appear when the launcher is called.

What's up with the Language indicator icon? The problem existed before any applications/files were added. What's up with my icons not changing color? The theme obviously supports it, it's just not happening.

0
  • Try regenerate icon cache for all themes

    sudo find /usr/share/icons/* -maxdepth 0 -type d -exec echo -e "\n"{} \; -exec gtk-update-icon-cache -f {} \;
    

    Cache file created successfully. ie OK

    No theme index file. ie it wasn't a theme folder. Only if you think otherwise, so index.theme is missing.

    The generated cache was invalid. ie there is a problem.

  • Not solved, Try reset theme preferences to defaults:

    dconf reset -f /org/gnome/desktop/interface/
    dconf reset /org/gnome/desktop/wm/preferences/theme
    

References:

  • 1
    1st command resets my icons to Ubuntu-mono-light. 2nd resets my theme to Ambiance. Language icon stays dark. – DualBooty Mar 19 '14 at 20:10
  • hmmm, have you tried with other user account, if it has same behavior? – user.dz Mar 19 '14 at 20:28
  • 1
    Same problem with other user account. Other custom icon themes seem to work properly. Maybe it is a bug with this one theme. Strange, because the light icons are there in the directory, they just aren't being displayed. And it's a widely-used icon theme. – DualBooty Mar 21 '14 at 0:47
  • @DualBooty, could you try gtk-update-icon-cache as updated my answer. – user.dz Mar 29 '14 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.