2

I have a Synology NAS box on which I keep my videos. This folder is shared out using NFS.

One machine of mine, running Ubuntu 13.10 has been having problems accessing this shared folder. None of the other machines in the network (including other 13.10 machines) are having any problems.

Last night I did a wipe and load of the problem-proned machine, set up the shares then watched a movie. It all worked well. Then tonight it's back to the same errors as before.

I try to open the share in Nautilus and I get the error "This location could not be displayed. You do not have the permissions necessary to view the contents of "(name of share)"

Absolutely nothing has been changed since it was all working right last night!

If I go to the terminal and try to do a directory listing, I get "ls: cannot access (share name): Permission denied.

Showmount -e (ip address) shows the correct share in the list.

The FSTAB command is as:

10.42.1.95:/volume1/video /home/(user)/videosharename nfs rw,hard,intr,nolock 0 0

This FSTAB statement has always worked with the Synology shares (at least, since Ubuntu 13.04).

I've done a wipe and load three times now trying to clean out any possible bugs, but I'm starting to doubt it's the configuration since it works fine, then mysteriously dies on me.

After each wipe and load I install and configure Samba and NFS:

sudo apt-get install samba samba-common sudo apt-get install python-glade2 sudo apt-get install system-config-samba sudo apt-get install nfs-common

I'm really not sure what else to check! Any help would be appreciated.

--- edit: found the problem, although I still have a hard time believing it: I replaced the NIC card and everything has worked since.

0

I am not sure if you are still encountering errors, but I had an issue with my Synology and Ubuntu 12.04. I would loose permissions for my NFS mounts constantly.

I enabled NFS v4 on the Synology and my fstab file now looks like this:

# NFS home directory
#topher:/volume1/nfs_home    /home   nfs     nfsvers=3,nouser,rsize=8192,wsize=8192,atime,auto,rw,dev,exec,suid      0       0
topher:/volume1/nfs_home     /home   nfs     nfsvers=4,nouser,rsize=8192,wsize=8192,atime,auto,rw,dev,exec,suid      0       0

It seems to be more stable and I haven't lost permissions yet, which was a daily occurance before.

  • I forgot to update my post here.. I found the culprit: a faulty NIC card! Last thing I would have thought of. But the card would reach the server, but it seemed to constantly lose some settings or the other and the permissions in Synology or Ubuntu would get lost. I replace the NIC and now the shares mount flawlessly! – Cranky Jun 6 '14 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.