1

I believe I have installed all the prerequisites that the manual listed...For Building under Linux:

Download RDPDesk source
g++
autotools-dev
libxt-dev (>=1.0.6-0)
libgtk2.0 (>= 2.18.0)
libglib2.0 (>=2.22.0-0)
x11proto-core
libwxbase2.8 (>= 2.8.9)
libwxgtk2.8 (>= 2.8.9)
libssl-dev

I then ran these commands in the location where I unpacked the RDPDesk files

./autogen.sh
./configure

I believe these go through fine, but If you want me to post the results, I can. Last, but not least, I ran these commands

make
sudo make install

but it errors out. Result below...

rdpdesk-FRDPOptionsDialog.o rdpdesk-  FRDPKeyboard.o rdpdesk-autoupdate.o rdpdesk-CatcherWindowID.o -pthread -Wl,-Bsymbolic-functions -Wl,-z -Wl,relro  -L/usr/lib/x86_64-linux-gnu -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8 -lglib-2.0 -lssl -lcrypto -lXaw -lz -ljpeg -pthread
/usr/bin/ld: rdpdesk-RDPConnection_nix.o: undefined reference to symbol 'gtk_widget_reparent'
/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[3]: *** [rdpdesk] Error 1
make[3]: Leaving directory `/home/fmccrary/Downloads/rdpdesk-3.2/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/fmccrary/Downloads/rdpdesk-3.2/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/fmccrary/Downloads/rdpdesk-3.2/src'
make: *** [all-recursive] Error 1

Any help would be greatly appreciated.

1

gtk_widget_reparent is part of the GtkWidget class. If you're missing that, you're missing some GTK development files. Their packages tend to have a -dev tag on the end. You probably just need:

sudo apt-get install libgtk2.0-dev
  • I believe I installed this package already, but I ran the command again to verify. Reading package lists... Done Building dependency tree Reading state information... Done libgtk2.0-dev is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded. – user111861 Mar 19 '14 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.