0

I don't know if this is a netbeans or Ubuntu or Java problem. But I'm running Ubuntu 13.10 64bit, and trying to create a jar file from my java application that I've created with Netbeans IDE 7.0.1.

This is what happens when pressing the "Clean and Build" button

init:
deps-clean:
Updating property file: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build/built-clean.properties
Deleting directory /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build
clean:
init:
deps-jar:
Created dir: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build
Updating property file: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build/built-jar.properties
Created dir: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build/classes
Created dir: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build/empty
Created dir: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build/generated-sources/ap-source-output
Compiling 11 source files to /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build/classes
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/src/Connect.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Copying 17 files to /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build/classes
compile:
Created dir: /home/jeggy/Skjøl/NetBeansProjects/KTEditor/dist
Copying 1 file to /home/jeggy/Skjøl/NetBeansProjects/KTEditor/build
/home/jeggy/Skjøl/NetBeansProjects/KTEditor/nbproject/build-impl.xml:990: The following error occurred while executing this line:
/home/jeggy/Skjøl/NetBeansProjects/KTEditor/nbproject/build-impl.xml:834: copylibs doesn't support the "excludeFromCopy" attribute
BUILD FAILED (total time: 0 seconds)

Could someone explain or help me to get this fixed?

0

It's just a simple Netbeans bug file. Click on the link on the second to last line which is /home/jeggy/Skjøl/NetBeansProjects/KTEditor/nbproject/build-impl.xml:834:

Remove the attribute of excludeFromCopy – not the whole line, only the piece of code associated with it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.