5

As the title says,

How can I disable or re-assign the "semi-maximize left" keyboard shortcut in Ubuntu 13.10? By default it is bound to Ctrl + Super +

I have tried to change the bindings for the "put left" action with compizconfig-settings-manager as suggested by the previous question for Ubuntu 12.04. This however no longer works in Ubuntu 13.10.

This question is motivated by the keyboard shortcut conflicts between the default Unity desktop and IntelliJ IDEA.

  • Refer to the previous question and if that does not give a solution, let me know Previous question – Arun Seshan Mar 17 '14 at 11:03
  • possible duplicate of How can I reassign the semi-maximize keyboard shortcut? – Danatela Mar 18 '14 at 10:22
  • @Danatela I have tried changing the "put left" action with compizconfig-settings-manager as suggested by QA for 12.04. This however, had no effect. The "semi-maximize left" action is now defined in some other place. – Eero Aaltonen Mar 18 '14 at 11:13
  • 1
    @Sneetsher: Thanks for your suggestion. I tried dconf write... left-maximize "'Disabled'" but no effect. Interesting thing is that I had tab completion available up until unity/plugins/ – Eero Aaltonen Mar 21 '14 at 14:12
  • 1
    A blog post about keymap conflicts. – Eero Aaltonen Apr 3 '14 at 11:51
3
+50

For 13.10

  1. Open CompizConfig Setting Manager (ccsm)
  2. Look for Ubuntu Unity Plugin in Desktop groupGeneral Tab:
  3. Disable:

    • Key to vertically maximize the focused window to the right
    • Key to vertically maximize the focused window to the left

Or just run:

dconf write /org/compiz/profiles/unity/plugins/unityshell/window-right-maximize "'Disabled'"
dconf write /org/compiz/profiles/unity/plugins/unityshell/window-left-maximize "'Disabled'"

For 14.04

  1. Open CompizConfig Setting Manager (ccsm)
  2. Look for Grid in Window Management group → Binding Tab:
  3. Disable:

    • Left maximize
    • Right maximize

Or just run:

dconf write /org/compiz/profiles/unity/plugins/grid/left-maximize "'Disabled'"
dconf write /org/compiz/profiles/unity/plugins/grid/right-maximize "'Disabled'"
| improve this answer | |
  • I already accepted your answer, but if you have links to official documentation, they may count to your favor by possible future voters. – Eero Aaltonen Mar 24 '14 at 9:32
  • 1
    Yep, If I got some I will put them. Just to mention for dconf commands, I made change through ccsm and monitor changes using dconf watch /, Ref: man dconf – user.dz Mar 24 '14 at 9:52
  • For anybody wondering, the 14.04 solution still works in 16.04. – John P Bloch Jan 19 '17 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.