2

I try to have a USB device recognized as being part of my user group. So I don't have to issue a sudo during development time when I debug my program which access those devices. Especially painful when using Netbean or Eclipse.

The udev rules never worked :

$ cat /etc/udev/rules.d/40-usbio.rules
SUBSYSTEM==”usb”, ENV{DEVTYPE}==”usb_device”, MODE=”0664”, GROUP=”odroid”,
ATTR{idVendor}==”04d8”, ATTR{idProduct}==”003f”

I also tried with mod MODE=”0666” and MODE=”0777”.

The weirdest part is that my USB camera has the same privileges and is part of the same group(root). But it never requires a sudo when I use cheese nor camorama.

ls -l /dev/bus/usb/001/013  ---------------> camera
crw-rw-r-- 1 root root 189, 12 Mar 16 21:25 /dev/bus/usb/001/013

ls -l /dev/bus/usb/002/007 ----------------> usb device
crw-rw-r-- 1 root root 189, 134 Mar 16 21:32 /dev/bus/usb/002/007

I also want to do the same with an arduino, but even with the proper rule file, it just does not work. Even after restarting udev or the computer.

How to fix this?

1
3

I'd add a NAME="my_device" in order to create the corresponding node.

And check your quotes, replace by ". It could be just that.

2
  • 1
    thx i cant believe i did not see the " problem it works :-)
    – user254885
    Mar 17 '14 at 15:38
  • 1
    Don't forget to vote/mark your question as answered please. Mar 17 '14 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.