I installed Ubuntu yesterday alongside Windows 7 and whenever I start my computer I don't have the option to boot Windows. When the computer starts it goes straight to Ubuntu without giving me an OS selection menu. When it goes to Ubuntu it gives me Ubuntu repair options and Ubuntu normal start option. I still have all of the Windows 7 files on my hard drive, but Windows 7 has no way to boot.

  • It just happened to me after installing Lubuntu 14.04 LTS alongside Win7, however after running the software updater in Lubuntu the GRUB OS selector came back. Might be worth a try before you go re-installing everything.
    – user329955
    Sep 24, 2014 at 3:54

6 Answers 6


Run fdisk -l on terminal to check the windows partition.

If you found it, then type update-grub

Then reboot

And you will able be able to choose your selected OS

If permission is denied on running fdisk -l alone, add administrator privileges by entering you password after writing this code into terminal sudo fdisk -l

  • 1
    Nice! This worked for me, using Ubuntu 16.04 and Windows 7. I had three partitions: 1 for Windows 7, 1 for Ubuntu, and 1 for Ubuntu swap. I installed Windows 7 first on sda/1, then installed Ubuntu on sda/2 (and sda/3 for the swap). I booted into Ubuntu, ran fdisk -l from the terminal: Windows was shown as an NTFS partition. I then ran sudo update-grub, and the output showed Found Windows 7 (loader) on /dev/sda1. I then restarted my computer and Windows 7 showed up in the boot list! Thanks for this answer Muhammad :) May 20, 2016 at 2:03
  • Worked also for me! I installed Ubuntu 16.04 LTS and I had Win7 installed. Now I can see both options in boot menu. Thank you!
    – jjepsuomi
    Jul 5, 2017 at 12:36

I had the same problem! After starting the computer the GRUB Boot loader displayed UBUNTU and 2 further entries but not Windows. After long trying I succeeded by performing the following steps:

  • Find out on what hard disk and what partition WINDOWS is installed.
  • This you can do after opening a terminal and type at the prompt

    sudo fdisk -l

    (this must be done with administative rights, so you will be ask for your password). You will now get a table of your partitions with device names like /dev/sda1, /dev/sda2 .. and so on.

If you have installed windows it might have type NTFS. This means if the second entry in this table is like this:

Device...Boot.....Start...End......Blocks......Size .........Id.....System    
/dev/sda1..*...2048..467118879..467116032..222,8G   ..7.....Linux    
/dev/sda2 ..467118080...961144831....494026552..235,6G  7.....HPFS/NTFS/exFAT    
/dev/sda3 ..1270138878...1953523711..341692417..7,6G        5.....Extended    
/dev/sda5 ..1270138880...1945182207..337521664..7,6G        83....Linux

windows is installed on the second partition of the first hard disk (sda2)

(In my case both operating systems were installed on one hard disk with 2 partitions, on the first I had installed UBUNTU and Windows 7 on the second. ) Press C for accessing the GRUB command prompt. At the Grub-Prompt enter the following 3 commands:

Grub>   set root=(hd0,2)
Grub>   chainloader +1
Grub>   boot

Notice: In the command set root = (hd0,2) after hd type the (zero-based) number of the hard disk (here 0 ) and after the Comma the Number of the partion (here 2) . If your windows partition is sdb1 you must type set root=(hd1,1) if it is sdb4 type set root=(hd1,4) etc…

Now Windows should boot!

Now you might want to have Windows 7 permanently as a menu item in the GRUB Boatloader menu. This you can get as follows:

menuentry 'Windows 7' {
   set root=(hd0,2)  
   chainloader +1  

Save the file and close it.

Open a terminal and type on the command prompt:

sudo update-grub

After restarting my computer I got a further entry with windows 7 in the GRUB menu, so I can chose between Ubuntu and Windows.

  • where should i save the menuentry? Mar 9, 2016 at 9:59
  • I'm getting "bootmgr is missing" is this fixable? I do not have the windows CD (read that it would be required to fix). Is there a way to fix this any other way? Aug 22, 2016 at 21:52
  1. First, restart your PC or laptop.

  2. After restarting you see the Grub menu. Select Advanced Options for Ubuntu (with the arrow keys; press Enter to confirm).

    Grub menu screen shoot

  3. In the Advanced Options menu you will see an entry Recovery Menu that you need to select.

  4. Carefully select the grub – Update grub boot loader option.

    Recover menu screen shot

  5. It will automatically add an entry for Windows 7/8/10 to the boot menu.

  6. To restart, press Ctrl+Alt+Del.

  7. The system will restart and you finally have a option to select Windows 10/8/7. Select Windows and finally you have with your Windows OS.

  • I tried it thousand ways and this solution only worked. Nov 30, 2018 at 13:10

First thing first, you need to repair your WIn7 bootloader, and you can visit this page to learn how to do this. Write down on a piece of paper the required commands for fixing both boot and mbr. You'll be using those codes after getting to the Command Prompt screen.

Next you can download Boot Repair iso image as suggested in the previous answer by 'user3005324'. Choose 64 bit iso image if you have installed Ubuntu 64 bit or choose 32 bit iso image if you have Ubuntu 32 bit. I hope Win7 is the same architecture with Ubuntu, I mean you have either Win7 32 bit and Ubuntu 32 bit, or you have Win7 64 bit and Ubuntu 64 bit.

Burn the iso image, and restart your computer with the new Boot Repair CD in tray. You can write Boot Repair iso image on a USB pendrive with Unetbootin tool if you don't have a regular CD to use. Read instructions on how to use Unetbootin in Linux/Ubuntu, they are located at the middle of this page: http://unetbootin.sourceforge.net/ .

After Boot Repair cd or usb pendrive finish loading, you can press the 'Recommended Repair' option, wait to finish and after you get the message 'success' you can reboot and use Win7 and Ubuntu which will be present both in your start-up boot menu.

  • 1
    Though it might work, you might want to have a quick look at the solutions below, which might solve your problem more easily (start by updating grub)
    – Kantan
    Feb 6, 2017 at 15:29

1> boot into ubuntu live cd and do a simple os-prober in terminal

2> does it show win7?

If yes, you are safe.

Just follow this link https://help.ubuntu.com/community/Boot-Repair

if not, you are probably screwed.Probable reason to that is windows was installed in LEGACY BIOS and u installed ubuntu in UEFI BIOS (provided your computer supports this new bios version) which means u have to reinstall everything.

But if your computer doesn't support UEFI bios, and both operatng systems are installed in legacy bios, then the above link should work.

  1. Restart your PC.
  2. Choose "Advanced options for Ubuntu".
  3. Choose recovery mode
  4. Update "grub"
  5. It will automatically load the other operating systems in the boot menu.

Precondition : you should have installed Ubuntu with "install Ubuntu along side with other operating system" option at the time of installation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.