2

I have Ubuntu 12.04 LTS and I want to know what is a tty login. I was opening my laptop and the screen went black and was written "Ubuntu 12.04 LTS harshira-HP-ProBook-445-G1 tty1". Now it does not go through this. What is a tty? And how do I bypass the tty login so that I can use my PC in graphical mode?

  • Have you tried using Ctrl+Alt+F7 when you get the black screen? What happens if you have tried? – jobin Mar 27 '14 at 17:35
  • Seeing the command line interface like this usually means that the graphical one has failed (not that you're ending up in the wrong place). The answer given will work if X is running but I'd be surprised if that applies here. – Oli Mar 28 '14 at 10:30
  • X mode is also not working. it said: mountall: swap is terminated with status 255 like i said below – Jatttt Mar 28 '14 at 11:47
7
+25

Simplest solution first, have you tried Ctrl+Alt+F7 (Not F8)? If this doesn't work, try this:

  1. Login from the command line using your username and password.
  2. Try starting the lightdm service.

    sudo service lightdm restart
    

Otherwise, if your computer displays a message there's something wrong with the swap, you could try doing sudo swapoff -a and repeat the above steps. If they work now, something probably is wring with your swap.

That's all I have now. If these don't work, try posting some more info.

  • He'll probably have to export his DISPLAY variable too. – Seth Mar 27 '14 at 18:27
  • I pressed ctrl+alt+f7. It said – Jatttt Mar 28 '14 at 9:03
  • @Jatttt It said what exactly? – sayantankhan Mar 28 '14 at 10:05
  • sorry. it said mountall: swap is terminated with status 255. – Jatttt Mar 28 '14 at 11:45
0

tty is the communication module with the kernel. On a tty port, you can telnet data to kernel. It is one of the ttys which hosts your display.

It's Ctrl+Alt+F7 for the tty containing display. If you press Ctrl+Alt+F1 or F2 up to F6, you can open new connections to your kernel.

If you don't have unsaved information you can try killall -u <user_name> and it kills everything except kernel.

0

As others have explained, tty (teletype) is the base communication module for the kernel. It is the first layer of communication a user has with the kernel itself, prior to loading a GUI and etc.

It looks like when you closed your laptop, the computer attempted to hibernate, which caused the swap to turn off. I have had this issue a few times on my laptops. The best thing I can tell you is to go into the Power Settings and make sure to change the action that happens when you close the lid so that it does not hibernate.

If you had your GUI working prior to this, then I suggest a hard reboot (hold down the power button until the computer turns off, then turn it back on) as long as you are not afraid of losing anything. If everything works, then it proves the above stated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.