I have Asus X53S laptop running Ubuntu 12.04.
On my previous 12.04 installation, suspend was working.
Now, after waking up from suspend mode, all I got, was a blank screen.

What I've tried so far:

  1. The script mentioned here
  2. Adding acpi_osi=Linux at GRUB_CMDLINE_LINUX=""
  3. Adding quiet splash nolapic at GRUB_CMDLINE_LINUX_DEFAULT=""
  4. After these, I ran sudo update-grub
  5. Also, disabled, requesting password after wake up


  1. Now, the screen after wake up isn't blank, but it's the last screen that was displayed before the suspend (probably).

  2. Moving the mouse, shows nothing - which is, the display is dead.

Some progress:

  1. Switching to tty1 (Ctrl + Alt + F1) got me at a terminal with a working screen. From which I could use sudo lightdm restart, which did nothing.

  2. After that, I typed who and saw that my user was connected to tty7, so I changed to it, and voila, I have now access to my session, as it was before the suspend.

But with problems:

  1. Probably the graphics are messed up. The border of the right click dialog is a thick white one (about 4mm).

  2. My wallpaper doesn't show up, and instead I get this: wallpaper error and border of terminal window

Look the wallpaper, and also, the border of the terminal window.

On a sidenote, my laptop has a Nvidia GTX520M GPU (with the "great" optimus technology).
Some related info:

  1. Running Additional Drivers program, I see that the version 331 of Nvidia Driver is activated and currently in use
  2. I remember that at my previous installation I had installed BumbleBee.

Should I try deactivating the proprietary driver, removing it, and then installing BumbleBee?


I finally solved this by doing the following:

  1. Opened Additional Drivers app, and Deactivated the driver in use
  2. Rebooted (something was wrong with the cursor, as it was going way past the screen on the right
  3. Ran all the commands from well my previous question regarding a problem with the same laptop.

Now, it wakes up from suspend successfully! :)

  • Mark as answered. :D – Dusan Milosevic Mar 16 '14 at 20:01
  • @DušanMilosevic: I can mark it as answer after 22h :( Will do that tomorrow :) – Chris Mar 16 '14 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.