1

Suddenly, after upgrade to Linux kernel 3.11.0-19, my wireless card with the ath9k driver is no longer seeing the 13th channel, even though it worked fine for the last year and half. It also still works fine on another Ubuntu laptop and an Android phone.

How can I re-enable the 13th channel? It is very necessary as most of the channels are taken here.

1
  • It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. No internet then go to this link for running the script without internet. <ubuntuforums.org/showpost.php?p=12350385>
    – Wild Man
    Mar 14, 2014 at 22:27

3 Answers 3

1

I installed the wireless-crda and the iw packages which automatically seem to have fixed things, before I saw these replies. Thank you for the answers, however!

1
  • dude, why isn't this installed by default???
    – mchid
    Aug 19, 2015 at 6:33
1

I seem to be having the same problem with Ubuntu 20.04, switching from Kernel 5.4.x to 5.13.x. Installing wireless-crda did not help at all. On an Arch Linux forum I found the remark that crda is actually deprecated over wireless-regdb.

Anyway. What solved it for me, was to force the regdomain when loading the cfg80211 module:

Add a file /etc/modprobe.d/cfg80211.conf with the content

options cfg80211 ieee80211_regdom=DE # or your country's 2-char ISO code.
0
0

You need to set your regulatory domain

Edit your /etc/default/crda and set your country code.

There is more info by running dmesg.

See. regulatory domain

1
  • While this is true, if you run dmesg you should see that it still initializes as 00 before changing to whatever regdom sets. So, if you are expecting a frequency outside channels 1-11 you are basically out of luck these days. Oh, you can change to the correct domaing but you will keep getting kicked off the channel every time it initializes
    – mchid
    Aug 19, 2015 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.