I tried to use time command with -f option to format the output of time, but I get the following error:

-f: command not found

Then I tried to use other options -a, -o, etc and I get the same error. Not even time --version doesn't work (--version: command not found).

Don't tell me to read the man because I already do it by many times... All these options are specified there. So, where could be the problem?

  • Does sudo apt-get install --reinstall time help? – jobin Mar 14 '14 at 17:53
  • 9
    Or maybe the internal shell time with /usr/bin/time – Rmano Mar 14 '14 at 17:53
up vote 81 down vote accepted

Well, even if you don't like it, I will put you to read again with more attention man time. At the end of EXAMPLES section you will find:

  Users of the bash shell need to use an explicit path in order to run
  the external time command and not the shell builtin variant.  On system
  where time is installed in /usr/bin, the first example would become
       /usr/bin/time wc /etc/hosts

So, I'm assuming that you use bash shell which uses an internal, shell builtin, version of time. You can check this using the following command:

type time

and the output will probably be:

time is a shell keyword

If this is the case, then is clear, to use the real time command, you must to use its explicit path: /usr/bin/time.

Further, if you don't want to use anymore the shell builtin time, you can create a permanent alias as follow:

alias time='/usr/bin/time'

This will overwrite the shell builtin time because the command:

type time

will give the following output now:

time is aliased to `/usr/bin/time'
  • Very good explanation, thanks! I went crazy because of this problem. – user258266 Mar 14 '14 at 18:06
  • 5
    for the shell built commands: {info time} and {type time}. For the binary commands: {which time} and {man time} – Michael Martinez Mar 14 '14 at 19:09

Since, as the other answers explain, time is a shell keyword, the only option available to you is -p:

terdon@oregano ~ $ help time
time: time [-p] pipeline
    Report time consumed by pipeline's execution.

Execute PIPELINE and print a summary of the real time, user CPU time,
and system CPU time spent executing PIPELINE when it terminates.

  -p    print the timing summary in the portable Posix format

So, you need to run the time that's in /usr/bin. Here are a few ways to do so:

  • Use the time executable instead:

    /usr/bin/time -f %Uuser ls >/dev/null
  • Use \ which causes your shell to ignore aliases, builtins and keywords and instead search your $PATH for a matching executable:

    \time -f %Uuser ls >/dev/null 
  • Use the command builtin which does the same as the above

    command time -f %Uuser ls >/dev/null
  • Use a different shell, one that has no such keyword. For example sh (which is actually dash on Ubuntu

    sh -c "time -f %Uuser ls >/dev/null"
  • Use which, which will search through your $PATH (OK, this one is silly)

    $(which time) -f %Uuser ls >/dev/null

The bash and zsh shells have their internal time command. You have to use

/usr/bin/time -f ...

BTW, I discovered that using (from zsh):

~% which  time
time: shell reserved word
  • 1
    Thanks for your quick reply, +1... but I must to accept the other answer as it has some more good explanations. – user258266 Mar 14 '14 at 18:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.