I tried to install lsblk, but I got this error message:

# apt-get install lsblk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package lsblk

I am using Ubuntu Server 10.04 64-bit.

If lsblk is not available then what is the best substitution for it?

  • lsblk is a default command.Why did you try to install it. Mar 14, 2014 at 11:47
  • # lsblk No command 'lsblk' found, did you mean: Command 'lslk' from package 'lslk' (universe) lsblk: command not found Mar 14, 2014 at 11:48
  • exactly how you call lsblk? What's the output of echo $PATH?
    – Braiam
    Mar 14, 2014 at 12:40
  • just lsblk the output of echo $PATH is /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games Mar 14, 2014 at 13:04

3 Answers 3


Use blkid from the util-linux package instead:

sudo apt-get update
sudo apt-get install util-linux

  • This command worked for me; I didn't even have to install anything. I did have to have root permissions to see anything.
    – Warren Dew
    Oct 31, 2014 at 23:18
  • sudo blkid will list all your partitions. Jun 21, 2017 at 1:13

From the @Oli's comment , lsblk was not included in the util-linux package for Ubuntu 10.04 LTS versions.

See this Ubuntu 10.04's util-linux package file list.So you can't able to run lsblk command on Ubuntu 10.04 LTS.

  • it said "util-linux is already the newest version." Mar 14, 2014 at 11:50
  • try to reinstall it by running sudo apt-get install --reinstall util-linux Mar 14, 2014 at 11:52
  • still not working. Mar 14, 2014 at 11:56
  • did you have coreutils package sudo apt-get install coreutils. Mar 14, 2014 at 12:01
  • i tried but still not working. Mar 14, 2014 at 12:04

(about ten years later) meet same situation on an old pc.

yes, ubuntu10 util-linux no lsblk command.

one workaround: get binary from other version .deb

I steal a binary from other release version (maybe ubuntu14) util-linux deb,
and it just work.

# I use x86 system, you can find other arch in same directory of this link
$ wget http://old-releases.ubuntu.com/ubuntu/pool/main/u/util-linux/util-linux_2.20.1-1ubuntu3.1_i386.deb

$ mkdir OUT

$ dpkg -x util-linux_2.20.1-1ubuntu3.1_i386.deb OUT

$ ls -lh OUT/bin/lsblk
-rwxr-xr-x 1 chen chen 43K 2014-06-18 09:21 OUT/bin/lsblk

other workaround: compile from source

I tried util-linux v2.38.1.tar.gz.
not success, maybe system to old for the last version of util-linux.
I didn't try other version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .