0

I have a buzzing constantly from my speakers when no sound is being played.

If I open sound settings, the speakers POP and then they are silent. (I don't even have to mess with any of the settings.) Once I exit, the speakers POP again and then the buzzing comes back. If I have anything that plays sound on, the buzzing goes away.

I know others have tried turning off automute. I have tried turning off automute in alsamixer but the buzzing does not go away.

I am using a lenovo y410p. Two sound cards show up in alsa mixer: HDA Intel MID and HDA Intel PCH:

EDIT:

I should also note that in alsamixer, for sound card 0[MID] I do not have any options for volume control. I only have these in alsamixer for sound card 1[PCH].

Audio Devices:

cat /proc/asound/cards
0 [MID ]: HDA-Intel - HDA Intel MID
HDA Intel MID at 0xc2610000 irq 49
1 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xc2614000 irq 50

Sound card information from the terminal can be found here: my google doc

New discovery:

When my computer is plugged in and I adjust any setting of the volume (mute, unmute, volume up, volume down), the buzzing goes away. As soon as I unplug my computer, the speakers POP and the buzzing comes back.

When I plug the computer in, with the speakers buzzing, the buzzing continues until I adjust any setting of the volume (mute, unmute, volume up, volume down). Then the buzzing goes away.

This suggests to me that "auto-mute disabled" is being overridden on battery power. It seems like auto-mute is activating on battery power regardless of whether or not I have auto-mute disabled. Am I off-base for thinking this?

I don't think this is an electrical issue, since I am dual booting windows and have no such problem with windows.

EDIT: Sunday March 16, 2014

Thanks to onecoder4u for pointing out that the buzzing only happens when the keyboard back-lighting is on dim, but not when keyboard back-lighting is off or on high.

Ok, I can live with not having my keyboard on dim. This solves the buzzing but not the popping issue. I still get a loud pop from my speakers whenever the computer switches between playing sound and not playing sound. I have no issues at all when my computer is plugged in.

I would mark this question as answered, but I am still having part of the problem.

  • Mute the microphone and line-in? – Elliott Frisch Mar 14 '14 at 4:02
  • We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Danatela Mar 14 '14 at 4:24
  • Microphone and Line-in are muted. I have posted the hardware information. Is this what you needed? – JasperKov Mar 14 '14 at 16:10
2

Not sure if this is your issue, but my Y410p with ubuntu 13.10 has this issue. I get a high pitch noise if I have my keyboard backlight on low brightness. If the keyboard backlight is off or on high no noise. I use the fn+space to toggle it.

  • Ok. Weird. But this was exactly my problem. Now the only issue is that I still get the loud POP from my speakers when it switches back and forth from playing sound and not playing sound. – JasperKov Mar 17 '14 at 2:29
1

I had similar problem, and it was caused by skype.

do you have skype installed? in my case I simply turned off ALL notification sounds on skype and this fixed the problem.

  • Thanks for the tip. :) However, I've seen other folks who have suggested this on other questions. I have no application installed that show up in the "applications" section of the sound menu. – JasperKov Mar 14 '14 at 15:57
0

I followed the steps on this post and it completely solved the problem: Popping noise from laptop speakers

The issue was the power save mode on the audio cards. Note, I used nano instead of gedit make changes to the configuration files.

0

Same exact thing happened to me, with Ubuntu (technically Mint) and a Y410P. If other solutions work for you please use them instead, because mine is a really backhanded, last-resort fix. I disabled my speakers and then bought a USB to stereo audio adapter and I plug my headphones into that instead of the regular jack. It works, and there is another way to get your speakers working again if absolutely necessary, but if you do this then do not forget to write down everything you do. It will save your life one day in the future, I'm sure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.