Original Question:

After I replaced my Ubuntu 10.10 with 11.04 all I get when I Ctrl+Alt+F1–F6 into a tty is a black screen. Also when I boot there's a while of black screen after grub2 menu is displayed. Then until just before gnome starts it stays black.

I have an Nvida Geforce Quadro FX 770M on my HP EliteBook 8530w. How do I get my ttys (aka 'virtual terminals') to work again?

My efforts in chronological order:

  • So grub and gfx-payload seems to be the problem, I figured. I went along with this guide for higher tty resolution. Which led to the grub2 menu displaying in my native resolution rather than 800x600. The black screen problem remains.

  • I googlehit some bugreports on other nvidia cards having that problem.

  • I tried uninstalling the nvidia driver. No effect. Also tried different resolutions

  • With an older version of the kernel it works. Though not perfectly. The ttys are usable, black screen between grub2 menu and gnome start remains. Not really a solution.

  • Tried so much, that I lost track. Reinstalled grub2 and linux-image-2.6.38-8-generic. Then did this to my /etc/default/grub in accordance with the aforementioned guide (/etc/grub.d/00_header edited as well):

    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    To my surprise I can now use my ttys in native resolution. Black screen between grub2 menu and gnome login screen is still there though. That is annoying since I also use an encrypted disk thus having to enter my passphrase in total dark... Still looking for a solution but urgency is low.

  • Downloaded and installed a later version of nvidia driver. No difference to last edit.

  • Tried GRUB_CMDLINE_LINUX="vga="-parameter. No effect.

  • nomodeset has no effect. not even in combination with vga=...

  • Tried echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash no effect (see comment)

  • On the verge of resignation...

  • Bounty period soon to end.

  • 1
    Did you try "nomodeset" on the "quiet splash" line to disable kernel modesetting?
    – maco
    May 18, 2011 at 21:29
  • tried it allready in another configuration. now I tried it again. Still no worky worky ;) Thanks anyways.
    – con-f-use
    May 19, 2011 at 9:43
  • 2
    Con-f-use - I'm still confused :-) with the question - the TTYs you can still use natively but you have a black screen plymouth? Have you tried the framebuffer=y trick? ubuntuforums.org/showpost.php?p=9175901&postcount=4
    – fossfreedom
    May 19, 2011 at 21:26
  • 2
    As per guidelines (askubuntu.com/help/reopen-questions) this is a "Please reopen" request. I don't believe this is too localized -- it happens on all my machines with nVidia proprietary installed. "Unlikely to help future visitors" is incorrect: I am a future visitor, and I'm certainly hoping the answers will help me fix this exact problem. I don't think the question needs to be edited or reworded, it perfectly describes the issues I have.
    – Ash
    Apr 2, 2014 at 22:25
  • 1
    A bit of history: There used to be a "too localized" close reason but Stack Exchange took it away because people used it wrong half the time. This is one of those clear cases of not being "unlikely to help any future visitors," given the many people who've posted here about having the same problem. Commenters elsewhere have sent people here where the answers helped. I believe this is relevant even today; I'm voting to reopen. @Ash Oct 7, 2017 at 18:00

6 Answers 6


I experienced the same problem as you when I replaced Ubuntu 10.10 by a fresh install of Ubuntu 11.04 (and later on, Ubuntu 11.10): my "console" tty's were desperately blanks but actually working -- i.e. I could log in and enter commands that actually work, but there was nothing visible on my screen.

I spent a huge number of hours on Google and various Ubuntu forums, I tried plenty of suggestions and I finally came to the following conclusion: the problem is linked to the proprietary NVIDIA driver -- if I remove the proprietary NVIDIA driver and use the "nouveau" driver, the problem disappears but then of course I can't benefit from the hardware acceleration any more.

I managed to fix the problem on my system (ZOTAC ZBOX with on-board NVIDIA GT218) by using the Uvesafb framebuffer driver.

Here is the procedure I used:

apt-get install v86d
apt-get install hwinfo
hwinfo --framebuffer

From hwinfo's output, I picked up the "best" resolution compatible with my screen -- in my case 1280x800 24-bit -- and I added the following line at the end of /etc/initramfs-tools/modules file:

uvesafb mode_option=1280x800-24 mtrr=3 scroll=ywrap

(The string "1280x800-24" comes from the resolution I chose -- your mileage may vary.)

Then I rebuilt grub and initramfs images as follows:

update-initramfs -u

Finally I rebooted the system and my console tty's were finally visible again.

I don't use encrypted filesystem, so I cannot check whether or not the passphrase is to be entered "in the dark", but anyway I hope the above workaround will help you.

  • 1
    This worked great for me! Apr 19, 2013 at 8:39

I encountered the same problem, all ttyX terminals running (getty proccesses running), but no loggin prompt on either Ctrl+Alt+F1-6 (black screen with rest of splash picture on top). When I type in logname and password user is properly logged (who command). Only solution I found is to switch to text mode while boot proceeds.

1) edit: /etc/default/grub GRUB_GFXPAYLOAD_LINUX=text

2) and update of grub: update-grub2 update-initramfs -u

  • Been working on this all day. Your downvoted answer was the only fix thus far.
    – Krista K
    Jan 12, 2014 at 1:00

Similar problem

I found out that it had to do with the VGA on my motherboard which I wasn't using. When I connected a monitor to the mobo VGA and hit CTRL-ALT-F1 the tty displayed on that monitor instead.

Went to BIOS- set the vga to enable when there is no graphics card - everything's fine now.

Pity I reinstalled and formated everything before I got to this stage :(


If you are using proprietary drivers this is the fix

  • First of all, that script is really bad work. It doesn't create backups. It will replace flasely, if lines are commented out. It suggests wrong resolutions bits and wrong resolutions if you're using dual screens. Also it could be changed installing maleware anytime. Luckily I looked in the code before invoking it.
    – con-f-use
    May 20, 2011 at 0:34
  • Now to the actual issue: The changes suggested in the script didn't help much - if at all. I can see part of the pre-gnome loading screen now but not the password qurey for decrypting my disks. Also said loading screen fills only a tiny part on the top left of my screen. But I suppose this is only due to the changes I made beforehand and the fact, that I reactivated "quiet splash" in order to test the fixscript. Half of the options it sets are outdated anyways.
    – con-f-use
    May 20, 2011 at 0:38

Mine fades to black slowly, like some kind of security feature, If I login, and I gotta type my login name perfectly, press enter, then enter my password, enter. I can see stuff just fine. Maybe your screen is fading to black very quickly.

Try loging in. I don't think this is related to a graphics card, since I have had this with 11.04 and 11.10, and maybe the version before. On two cards, NVIDIA and ATI. (with fancy-super-secret-non-open source drivers)


I started experiencing this problem after making the required changes for wireless to connect even before user login to the desktop environment .

I followed the instructions provided at this page for achieving the same.

After these changes my sessions were not at the correct runlevel. I was able to get the tty console back by reverting the changes made in /etc/init/rc-sysinit.conf.

Now my tty consoles are working fine and the issue was not related to grub or display drivers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .