2

I installed squid v3 on ubuntu 13. Running squid3 -v responds with version 3.3.8 (yet I cannot find any squid script in /etc/init.d). I am able to run

service squid3 restart

(process shows as running). Any insight as to what I might have configured incorrectly? I noticed the missing squid after I made a change to the squid.conf file.
Thanks in advance.


I realized that squid was generating the squid.conf file in /etc/init & not /etc/init.d - I had installed squid via sudo apt-get install squid.

3

Your Ubuntu release uses already Upstart for starting services. That's why you can't find the init script for squid anymore in /etc/init.d/. Instead, you have to start squid via

sudo service squid3 start

BTW, you cannot use su here to become root and then call service squid3 start. For more information see Ubuntu bug #1303769.

The script /etc/init/squid3.conf is the init script used by upstart and nothing we should normally edit.

Instead, use /etc/squid3/squid.conf for setting your configuration options.

3

Service startup file for squid is /etc/init/squid.conf this services run as upstart which is very good to restart them use this

commands

To stop

sudo stop squid3

To start

sudo start squid3

To check status

initctl list

main advantage here is system boots faster and also if some kills the pid of squid3 kernel automatically restarts squid3 services in fraction of seconds with new pid.

for more information about upstart services

Below you will see in the /var/log/syslog messages

Apr 22 12:00:48 proxy02 kernel: [5864996.503368] init: squid3 main process (318) killed by KILL signal

Apr 22 12:00:48 proxy02 kernel: [5864996.503379] init: squid3 main process ended, respawning

2

Squid Installation generates the squid.conf file in /etc/init & not /etc/init.d on ubuntu - I had installed squid via sudo apt-get install squid.

1

Try looking in /etc/rc.d/init.d/

Your .conf file should be located in /etc/squid/squid.conf

  • thanks for sharing - there is no /etc/rc.d directory on this computer. I am aware of the conf file - I am making changes to it for testing purposes. – ali haider Mar 13 '14 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.