0

I have a new mini-PC Intel NUC N2820 and it has a fairly new wireless controller Intel 7260 (rev 73).

I downloaded the source, compiled and installed it.

But the problem is that during the installation I connected to wireless (in the beginning), entered the password for the wifi, and it even updated during the installation, but failed after the install was complete.

1

Is the driver loading? Check from the terminal:

lsmod | grep iwl

If not, load it and see if the problem is fixed:

sudo modprobe iwlwifi

If that fixes it, let's get iwlwifi to load on boot.

sudo -i
echo iwlwifi >> /etc/modules
exit

Do you have the latest firmware?

ls -al /lib/firmware | grep 7260

The newest is 683236 iwlwifi-7260-7.ucode; the older is smaller, 682892. If you have the older firmware, update it: Intel wireless 7260 driver crashes, how do I work around it?

Finally, look for clues:

dmesg | grep iwl
  • Hi, this is what I am getting from the dmesg [ 2.503391] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002) [ 2.509706] iwlwifi 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control [ 2.509856] iwlwifi 0000:02:00.0: irq 107 for MSI/MSI-X [ 2.853943] iwlwifi 0000:02:00.0: request for firmware file 'iwlwifi-7260-7.ucode' failed. [ 2.853946] iwlwifi 0000:02:00.0: no suitable firmware found! – KaziQ Mar 13 '14 at 21:27
  • You have no firmware file at all. Please retrace the process in the link I gave to install it. – chili555 Mar 13 '14 at 21:30
  • Yeah, I will and thank you for that. But that requires me to have internet access somehow. I'll use the ethernet port to get connected to internet and do just that or compile it myself. My question is, how is it that I use the wireless during the installation and can't after? – KaziQ Mar 14 '14 at 0:30
  • I haven't any idea why it works at all in the USB! There is nothing to compile; simply download the proper firmware in the proper location and reboot. If ethernet access is a problem, I can edit my question to show how to download it on some other computer and transfer it on a USB. Is that what you'd prefer? – chili555 Mar 14 '14 at 1:00
  • Anyway, after getting the internet working with a usb wifi stick, update solved the driver problem. Thanks for the help. – KaziQ Mar 14 '14 at 11:24
0

Had the same problem on a Toshiba Portege R30 (with intel wireless 7260, hence requiring the iwlwifi-7260-7.ucode firmware file).

Symptoms: Wifi ok during install of Ubuntu 12.4 from USB stick (alongside and already installed Windows 8.1), but afterwards, when using the installed Ubuntu, no Wifi servers were detected, and hence no wireless internet was available.

lsmod | grep iwl 

showed that the firmware file was not there while:

dmesg | grep iwl

showed also an error message that the firmware could not be found.

I downloaded the required firmware via:

sudo apt-get install linux-firmare

after which the required firmware file "iwlwifi-7260-7.ucode" was now present in: /lib/firmware

Rebooted and the Wifi worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.