2

I am trying to use Gedit as an IDE for learning C. So far everything is working great but i have this problem: when using ls in its embedded terminal I am unable to see all the files and directories in my workspace directory (only shows .c files but not the .out and other directories), yet when i run terminal from CTRL+ALT+T all the files in the current directory show.

I can't seem to figure out why this is happening, so any ideas would be greatly appreciated. it seems to me that only the colored files aren't showing in the embedded terminal and i need them to show.

thank you!

  • Do they show with ls -a? – Hugo Buff Mar 13 '14 at 12:20
  • No, its the same with ls. However, they do show when using ctrl+alt+T. but hidden files is not the problem, not being able to show colored filed or directories is the problem. for example, when using ls on my home directory in embedded terminal, all what i see is the examples.desktop, but not all the other directories in there. – ramez Mar 13 '14 at 12:26
  • Oh, so it's when running ls from the terminal within gedit. Sorry, I misinterpreted the question – Hugo Buff Mar 13 '14 at 12:30
4

The OP is asking about a problem in Gedit embedded terminal plugin.

The only problem here is that the colour scheme is not good i.e., white prompt on light grey background makes it almost impossible to work. To change the colour scheme follow the next series of steps:

  1. Open dconf-editor. If it is not installed, install it through the following command :

    sudo apt-get install dconf-tools
    
  2. Once installed, execute it using the following command :

    dconf-editor
    
  3. In the dconf editor window, go to org->gnome->gedit->plugins->terminal

    • deselect the use-theme-colors option.
    • clear palette settings
    • set foreground color: #FFFFFF
    • set background color: #000000

    enter image description here

  4. Now restart the gedit program.

    enter image description here

Observe that a colour scheme of black prompt over light background is now active.

  • Nope I already did that and modified my embedded terminal to look like the other terminal. my issue is with ls. I can't post a screenshot yet but the whole matter is not being able to see all the files in the present directory. /bin/ls solved but i'm still trying to make it work with just ls. – ramez Mar 13 '14 at 13:03
  • use dir instead of ls – kamil Mar 13 '14 at 13:11
  • solved by clearing palette settings. see my edit – kamil Mar 13 '14 at 13:25
  • @user257841 check my edit – kamil Mar 13 '14 at 13:27
0

Verify your .bashrc file, and see if it contains the following:

alias ls='ls --color=auto'

If it doesn't have, add it. It must help to show dotfiles too.

  • it says alias ls ='ls --color=auto' bash: alias: =:not found bash: alias: 'ls --color': invalid alias name – ramez Mar 13 '14 at 12:33
  • Try removing the space between ls and = so it says alias ls='ls --color=auto' – Hugo Buff Mar 13 '14 at 12:40
  • Type ls at your home folder and see if the output is colored. If yes, try the same with option -a – muniz95 Mar 13 '14 at 12:40
  • Are you trying this commands within gedit terminal? – muniz95 Mar 13 '14 at 12:42
  • Ok, I did make an alias to ls but the problem still persists. Please note that this is only happening in the terminal that is embedded within gedit, everything works fine when using ctrl+alt+T – ramez Mar 13 '14 at 12:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.