I have an XUbuntu installation that uses LightDM that for some reason unkown to me went gabooey yesterday - black screen with just the mouse pointer on booting. (TTY's still working.)

After much reading I've reinstalled LightDM and now I get to the XUbuntu splash screen but no further.

/var/log/lightdm/lightdm.log reports:

DEBUG: Seat: Failed to find session configuration xubuntu


DEBUG: Seat: Failed to find session configuration lightdm-gtk-greeter-ubuntu

Can someone tell me exactly what files LightDM is looking for and where it is looking for them?

There are .conf files with those names in /etc/lightdm, I've also tried copying them to other folders I've seen mentioned in posts. I've also tried adding specific xsessions-directory and xgreeters-directory options to lightdm.conf but nothing seems to work.

Any suggestions, much appreciated.


  • I have lightdm.conf and users.conf in /etc/lightdm, as well as a subfolder lightdm.conf.d. In lightdm.conf.d, I have five more .conf files. – Jos Mar 13 '14 at 11:45
  • @Jos - thanks for the info, I had the same files, but still no idea where lightdm was looking for the ones that failed. I gave up and re-installed. – jarsudsco Mar 18 '14 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.