2

I have two different audio output devices: an internal sound card and an external DAC/amp.

When starting an OpenAL application (I first observed the issue with Minecraft, but I suspect it affects all applications that use OpenAL for audio playback), the internal sound card is selected for output, and I cannot change the device using pavucontrol (or KMixer on Kubuntu). The option to select an alternate device is present, but choosing the device has no effect.

How can I select an alternate audio playback device for OpenAL applications?

3

The solution is to add the option allow-moves = true to the OpenAL configuration file (the per-user file is located at ~/.alsoftrc).

If you don't already have this file (it doesn't exist by default), you can copy it from /etc/openal/alsoft.conf or use this sample default configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.