10

I have installed a new laptop (Lenovo Z510) for dual boot Ubuntu 12.04 and Windows 7 64 bit. After several trials it now works, but I have a strange effect.

I always enter the Grub purple screen fine. Ubuntu always works. When I want to boot Windows however windows boots fine (I hear the Windows start sound) but I only see a blank, purple Grub like screen. I can operate Windows though, pressing three times the tab key and then enter shuts the PC down successfully.

Sometime a trick works like that: I press just the power key and the PC hibernates. When I switch on the PC afterward and choose Win7 in Grub again everything is working fine, this time with working screen. However I had to find the trick does not always work - maybe whether it works or not is just random :-(

The workaround is quite dirty, what can I do to get rid of it?

Thanks for your help!

  • I have same problem with 13.10, hope we'll find a solution – micnic Mar 15 '14 at 14:54
  • The problem is still there. I have not found a solution yet. Whenever the problem shows up I just reboot and try again... – TheOneWithNoClue Apr 6 '14 at 14:57
  • Did you try Boot-Repair ? – TuKsn May 10 '14 at 23:32
3

I had the exact same problem (I was able to listen to the windows login sound even when the only think I saw was the grub purple screen).

Luckily I found a workaround:

  • move the file 30_os-prober to 06_os-prober (because I wanted the windows entries to be listed first)
  • run sudo upgrade-grub

And now it works fine every time... I do not not understand why and I have not tried to isolate if update-grub is enough or not.

1

So this sort of worked for me. I moved the /etc/grub.d/30_os-prober file to /etc/grub.d/06_os-prober, then ran update-grub.

This puts windows on the top of the grub boot screen. Then I tried many different options to start, restart from windows and ubuntu and what I have noticed so far is if I let the boot via grub, proceed by it self with no manual intervention and let the default 10s pass, it will boot into windows with no issues.

However if I manually select the "Windows 7" option in the grub boot screen using my cursor and then hit enter, I get the dreaded purple screen in windows.

1

In my experience, this issue can appears if Video card drivers were not installed into the Windows system properly (Win 7 in my case).

The steps which helped me :

  1. Boot into Ubuntu

  2. Edit /etc/default/grub and uncomment the line GRUB_TERMINAL=console, then execute sudo update-grub

  3. Restart and boot into Windows

  4. Install / Reinstall Video card drivers (Intel HD + nVidia in my case)

  5. Restart and boot into Ubuntu again

  6. Restore /etc/default/grub to the previous state (comment GRUB_TERMINAL=console), execute sudo update-grub again.

Done.

Tested on:
Dell Inspiron 15 3000 Series, Os: Windows 7 x64, Ubuntu 16.04 LTS x64

  • Here is the purple screen I was seeing and this answer was the solution for my case. Moving the grub entry as suggested in other answers had no effect. – McMutton Feb 15 '18 at 12:53
0

I had the same problem I noticed I was booting to the 1st partition, the windows boot partition ~200mb When I instead selected the partition with Windows system installed on it, the boot proceeded normally

0

Had the same issue. It's more to do with Legacy v/s UEFI Boot mode. Win 7 is installed in Legacy mode while it's other way round for win 8.1 and above. If both win 10 and Ubuntu are installed in Legacy mode (for eg. if win 7 upgraded to 10). This issue may come. For me just disabling legacy mode from BIOS and enabling it again worked fine.

0

Well I have found a temporary solution to the problem... just go into your BIOS settings and set Windows bootloader to boot first (before Ubuntu)...

0

I had a similar problem when upgrading my dual boot Lenovo T440s from Windows 7 to Windows 10. It always worked fine with Win7 until the upgrade rebooted to start Win10. I then only saw the purple screen.

I booted into Ubuntu 14.04 and modified /etc/default/grub to uncomment GRUB_TERMINAL=console to disable graphical mode and changed GRUB_DEFAULT=0 to 3. After I ran sudo update-grub and rebooting, Win10 booted just fine. However, I then re-enabled graphical mode, changed default back to 0, ran sudo update-grub, and Win10 still booted fine.

So I think just running sudo update-grub solved my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.