0

I can't setup successfully a split-VPN on Ubuntu 13.10. I followed this guide, or this or this. Adding a route manually for the VPN-secured part allows successful ping's to VPN-resources as well as standard internet domains (like google.com). ssh into a remote machine works, too. Also, syslog reports the correct nameservers. But after 1 minute or so, the VPN part stops working. ping reports unknown hosts for the private resources, ssh freezes. route still shows all correct routes, though. Looking into syslog, no error messages are available. Trying to stop/restart the VPN client does usually not help. The standard VPN setup (not trying to split the tunnel) works without problems, but does not allow any external internet addresses, of course. Any ideas?

Update: Using one of the above guides and running in a different wlan network, no problems seem to occur. So could that problem be connected to my router (a fritzbox in my case)?

Update 2: In order to check the router, I connected via a Windows machine to the VPN. The same behavour as described above can be observed -- this seems to be a problem with my router, then.

1

Do you have PPTP Passthrough, or something like it, enabled on your router? If not, I suspect that your router might be blocking proxy traffic.

| improve this answer | |
  • Good hint, thanks! Yes, PPTP passthrough is enabled (this is also mentioned on avm's help site). – osdf Mar 15 '14 at 9:21
0

As indicated in my updates, this seems to be a problem with my router, a Fritz!Box (though I might have missed something). After some emails with the nice customer support at AVM, no resolution could be found. To get a working 'split'-VPN setup anyway, I decided to use SSTP instead of PPTP. Adding the necessary repo to 13.10 according to this link. Note that I had to change the repository name to precise in sources.list.d. Set up the connection according to this guide. This setup worked without problems for several hours from two computers behind the above router.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.