3

The Problem

Today LibreOffice just started to crash my entire KDE desktop every time I try open a file. It takes me to the login screen every single time and I have to log back in again (losing any saved work in other applications I might add).

I should mention that opening LibreOffice on its own (i.e. no saved file) does not crash. It is as soon as you attempt to open a saved file that it crashes. I have had Kubuntu for the past 6 months and it has never acted this way with LibreOffice.

What I have tried

Till now I have tried re-installing LibreOffice (both with apt-get remove and purge) and I have also tried installing the latest version of LibreOffice using their official ppa. None of them have worked unfortunately which is quite frustrating.

Looking at my update history, LibreOffice has not received an update within the past few days so I do not believe it is entirely at fault.

Has anyone else experienced this issue and know what to do to fix it?

System Information

Kubuntu 13.10 64bit running on Xorg-edgers

EDIT: So I found the Xorg log files:

[  2190.484] (EE) Backtrace:
[  2190.484] (EE) 0: /usr/bin/X (xorg_backtrace+0x3d) [0x7f019ba9ffdd]
[  2190.484] (EE) 1: /usr/bin/X (0x7f019b8fd000+0x1a6d49) [0x7f019baa3d49]
[  2190.484] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f019a9fd000+0xfbb0) [0x7f019aa0cbb0]
[  2190.484] (EE) 3: ?? [0x7fff34fb8768]
[  2190.484] (EE) 
[  2190.484] (EE) Segmentation fault at address 0x7fff34fb8768
[  2190.484] (EE) 
Fatal server error:
[  2190.484] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  2190.485] (EE) 
[  2190.485] (EE) 
Please consult the The X.Org Foundation support 
    at http://wiki.x.org
for help. 
[  2190.485] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2190.485] (EE) 
[  2190.485] (II) AIGLX: Suspending AIGLX clients for VT switch
[  2190.662] (EE) Server terminated with error (1). Closing log file.

Not entirely sure what is causing it but I am guessing this is the reason why LibreOffice is crashing?

closed as off-topic by Jorge Castro, chaskes, Eric Carvalho, Warren Hill, Braiam Mar 17 '14 at 23:21

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Jorge Castro, chaskes, Eric Carvalho, Warren Hill, Braiam
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Yes --- this is clearly a bug in the server. Are you using any proprietary graphic drivers? If not, you should report a bug to Xorg-edgers. If yes, things are more difficult. – Rmano Mar 12 '14 at 15:28
  • I have an optimus laptop so by default im using the mesa drivers. I have nvidia drivers but I have to explicitly use them by using bumblebee's optirun. Is there any workaround I could use right now to solve this? I cannot work on any coursework while open office continues crashing like this. – Michael Aquilina Mar 12 '14 at 16:14
  • I remember (can't find where) a problem with a proprietary driver using internal functions of the intel driver --- so causing crash. I do not think that using Xorg edgers PPA together with any proprietary driver is a good idea --- but I have an ATI hybrid so my experience is not direct. Try to add nvidia tags to see if someone can help. If I were you I would try to go back to standard drivers (no edgers) and to only open-source ones, but I understand that it could be a lot of work, so maybe it's worth to wait for suggestions. – Rmano Mar 12 '14 at 16:21
  • By the way, the most probable cause of the "new" crash is an update of the X stack or driver. LibreOffice is unlikely the cause here. – Rmano Mar 12 '14 at 16:27
  • 1
    That's what I figured. I received updates to X today so I'm guessing thats whats causing the issue. – Michael Aquilina Mar 12 '14 at 16:30