13

I installed Ubuntu with mostly default configuration; the keyboard seems not to detect the Alt-Gr key so that I can not type international characters.

How can I enable Alt-Gr key?

  • 3
    Have you tried blowing out the keyboard with canned air? Or have you verified that it works with a different OS? – Elder Geek Mar 12 '14 at 1:06
  • Try running xev | grep KeyPress in the terminal to see if it picks up keypresses from the hardware itself. – eccentricSam Mar 12 '14 at 2:18
  • 1
    You should tell us what you tried, what didn't work, which keyboard layout you have, etc. Nevertheless, I tried a tentative answer. – Rmano Mar 12 '14 at 3:30
  • I had similar problem (experimenting with dwm) and the problem was, that I accidentally switched to a keyboard which was Czech, but without AltGr as the dwm keyboard shortcuts were very close to switching keyboards. Switching keyboard back to "standard Czech" one resolved the issue. Now I will have to investigate, how to prevent switching the keyboards (what I do not use living all the time with Czech one - yes, even for programming). – Jan Vlcinsky Apr 13 '15 at 20:00
24

This answer has screenshots for Gnome-Shell (Ubuntu Gnome 13.10). I suppose it will be similar for standard Unity, but if not, please chime in.

First of all (and this is the most common problem), to have AltGr working you need a keyboard layout which uses it. For example, this is my keyboard layout (Settings -> Region and Language):

Screenshot: Region & Language settings

  • English (US, international with dead keys) has AltGr.
  • English (US) has NO AltGr.
  • English (international AltGr dead keys) has AltGr.

(My preferred layout is the third one, really).

If the layout does not map AltGr+Key to anything, like for example the default "English (US)", AltGr will not work even if it's activated in the Keyboard -> Shortcuts panel.

This is normally sufficient. To change the position of the AltGr you go to Settings -> Keyboard and set the "Alternative Characters Key":

Screenshot: Keyboard settings

For example, my keyboard has no physical AltGr key, so I mapped it to the Right Alt key.

Now with the third layout, pressing AltGr and n together gives ñ.

Compose (the option before) is a very different beast. If you enable it, then you will have a set of characters available with three (or more) keystrokes. For example, pressing Compose, o, e gives œ. That's three sequential keystrokes, not together.

Take into account that there is a bug related to the layout switching in 13.10 which is being worked on, so check it if you have problems changing layout.

| improve this answer | |
  • 1
    Thanks, this worked for me, the layout I chose when installing did not have Alt-Gr. – user257297 Mar 13 '14 at 15:26
4

In order to set up the Alt-Gr key you must go to (setting -> keyboard -> layout settings -> keyboard settings -> then go to the typing tab -> press and hold the Alternative Keyboard Key setting -> move you mouse down to select the key you want to assign Alt-Gr to. enter image description here enter image description here enter image description here enter image description here

| improve this answer | |
0

AltGr sounds like a lot of trouble for only a few symbols. A better choice might be the United States Alternative International keyboard. This one gives a choice of dozens of letters with diacritical marks . The k'bd is just like the standard k'bd except that the `~ ^' and the " are --dead-- keys ( delayed action ) until the next key is pressed. These are the accent grave, tilde, circumflex and the accent agut. Just these 5 added to all the vowels and many consonants gives dozens of extra characters . If you want to type the apostrophe by it self just hit the space bar. ( Or the quote sign ) I have Ubuntu 12.10 and it works OK. I used the instructions for Ubuntu 14.04 so I had to do some guessing but I finally got it to work.
http://www.wikihow.com/Change-Keyboard-Layout-in-Ubuntu

  ã â ś Ḱ ç ŕ ï ḿ ĝ  ĥ â ŝ ó õ------samples

the 'and the v = ǘ this u with 2 marks above it ,,, wonder where it is used ?

| improve this answer | |
  • 2
    You know, touch typing is about speed. With US Alternative International Keyboard you can jump over configuration troubles with AltGr but you loose all the speed for typing the language, which requires special marks which are on national keyboards available by single press like ěščřžýžýá etc.. – Jan Vlcinsky Apr 13 '15 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.