25

I installed VirtualBox and downloaded Ubuntu 64 bits. When I select Linux under VirtualBox, only Ubuntu 32 bits is shown. Am I doing something wrong that stops the 64bit option from appearing? My machine as a Windows 7 64 bit OS with 8GB of RAM.

VBox screenshot

  • I have translated your post to English, sorry but this site only accepts posts in English. Next time, try using translate.google.com. – terdon Mar 11 '14 at 16:06
  • My guess is that this is happening after installing the virtualbox package in Ubuntu 14.04. The VirtualBox installed by that package only appears to support 32 bit operating systems. – Reinier Post Sep 15 '15 at 11:12
  • In other words, this probably has the duplicate askubuntu.com/questions/534693/… – Reinier Post Sep 15 '15 at 11:13
  • I had this problem, and I had to go to BIOS and enable virtualiziation. That solved it. – Akavall Dec 9 '15 at 19:51
13

Your issue is that you need to create a 64bit virtual machine. You have probably created a 32bit one which is why the option does not appear. From the VBox website (emphasis mine):

64-bit guests

VirtualBox supports 64-bit guest operating systems, even on 32-bit host operating systems, provided that the following conditions are met:

  1. You need a 64-bit processor with hardware virtualization support (see the section called “Hardware vs. software virtualization”).

  2. You must enable hardware virtualization for the particular VM for which you want 64-bit support; software virtualization is not supported for 64-bit VMs.

  3. If you want to use 64-bit guest support on a 32-bit host operating system, you must also select a 64-bit operating system for the particular VM. Since supporting 64 bits on 32-bit hosts incurs additional overhead, VirtualBox only enables this support upon explicit request.

    On 64-bit hosts (which typically come with hardware virtualization support), 64-bit guest operating systems are always supported regardless of settings, so you can simply install a 64-bit operating system in the guest.

Warning

On any host, you should enable the I/O APIC for virtual machines that you intend to use in 64-bit mode. This is especially true for 64-bit Windows VMs. See the section called “"Advanced" tab”. In addition, for 64-bit Windows guests, you should make sure that the VM uses the Intel networking device, since there is no 64-bit driver support for the AMD PCNet card; see the section called “Virtual networking hardware”.

If you use the "Create VM" wizard of the VirtualBox graphical user interface (see the section called “Creating your first virtual machine”), VirtualBox will automatically use the correct settings for each selected 64-bit operating system type.

So, just try creating a new Virtual Machine and select Ubuntu 64 as the OS. All the settings should be correctly configured by VirtualBox and you should be able to install with no problems.

  • 3
    I had this problem and all I needed to do was go into the BIOS menu (Lenovo G50-80) and enable Hardware Virtualisation. Now 64bit ubuntu appears as an option for me in VirtualBox – Ogaday Jun 14 '16 at 11:52
  • 3
    BIOS needs to enable virtualization of course, but for me, I also had to uninstall Hyper-V ("remove windows 10 feature") which for some reason interfered with this – RLaaa Feb 1 '17 at 19:47
2

Most probably your processor is not the 64-bit one, thats why VirtualBox is not able to run 64-bit kernels,or in most cases of new computers VT (Virtualization Technology) which is required to run 64-bit guest is disabled in BIOS settings which you could change in BIOS section of your machine.

To check whether your processor is able to support VT or not,run the following commands in your terminal window.

 grep --color vmx /proc/cpuinfo.

 grep --color svx /proc/cpuinfo

As vmx is a flag for Intel's processor and svm is for AMD's processor. If the output shows vmx or svm your machine is capable to VT.

Not the answer you're looking for? Browse other questions tagged or ask your own question.