3

Hardware: Very old Dell Inspiron 6400 laptop, onboard video, no driver support. Planning on buying a new computer soon, but wondering if this is a hardware issue which could be solved by buying a new machine, or a software issue which can be solved with the machine I have by me not being a dolt.

Anyway, I'm trying to play Hearthstone on Wine 1.7.14 under Ubuntu 13.10. I've set my Wine to have a virtual desktop, because otherwise starting up Hearthstone locks my computer, as if a new process is getting mouse focus, but since that process doesn't start properly I just lose the ability to use my mouse (keyboard works fine though, and the system doesn't lag at all, just the mouse dies). When I start up Hearthstone in my virtual desktop, I get a popup in my virtual desktop telling me something about screen resolution or some such. I'm not quite sure what the problem is or how to fix it, and was wondering if anyone here could be of assistance. Unfortunately I'm new to this site so I can't post an image of the error message, but here's the text of the message:

Couldn't setup OpenGL for the requested monitor resolution

GLContext: failed to share context 40000: Success

Screen: could not setup GL for resolution (1152x864 fs=1 hz=60 wi...[error message gets cut off here]
GLContext: failed to share context 30002: Success

Screen: could not setup GL for resolution (1152x864 fs=0 hz=0 win...

Thanks for the help!

  • Just in the case that you have not been able to fix this issue, please run this command and comment the output, I had the same problem, apt-cache policy libgl1-mesa-dri libgl1-mesa-dri:i386 | grep -C1 Installed – DeFoG Mar 14 '14 at 20:12
  • @RevExNET I have the same problem, I ran the command you posted and get: dri:i386 | grep -C1 Installed libgl1-mesa-dri: Installed: 9.2.1-1ubuntu3 Candidate: 9.2.1-1ubuntu3 -- libgl1-mesa-dri:i386: Installed: (none) Candidate: 9.2.1-1ubuntu3. I have Linux Mint 16, do you have any idea how to fix this? – Marcelo Apr 5 '14 at 21:52
0

Thanks to RevExNET comment I solved this with the following command:

 sudo apt-get install libgl1-mesa-dri libgl1-mesa-dri:i386 

For me, only the :i386 was missing, but I'm guessing you need both.

I believe this is an issue faced by those using intel graphic cards.

  • Didn't work for me. I have radeon though. – Hi-Angel Oct 25 '15 at 10:34
0

I got the same error on my netbook. It seems to me that this error is related with https://bugs.winehq.org/show_bug.cgi?id=33407

I built wine with a patch attached to that bug. This helps me but I found out that my netbook (Atom N570, 1Gb RAM) is too slow :) Nevertheless you can try.

Download a build script from https://github.com/Unity3D-Wine-Support/Unity3D-on-Wine by commands below and then edit it. I'm not sure about 'build-essential' package but I think it is better to have it installed.

sudo apt-get install build-essential
sudo apt-get install git
git clone https://github.com/Unity3D-Wine-Support/Unity3D-on-Wine
cd Unity3D-on-Wine/Compile-Wine
nano compile-wine-ubuntu-32bit.sh

Replace version number 1.7.21 by 1.7.17 at line 48 and save the script. Then build wine and install it:

./compile-wine-ubuntu-32bit.sh
cd ~/wine-git
sudo make install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.