1

I compiled mono 3.0, xsp and other related libs. My web aplication directory is /var/www/mvctest/public_html I configured apache sites-default file just like in this tutorial I put my Mono+nancy application application inside /var/www/mvctest/public_html. When I start xsp4 in this directory, I get the following error xsp4

Listening on address: 0.0.0.0
Root directory: /var/www/mvctest/public_html
Address already in use
  at System.Net.Sockets.Socket.Bind (System.Net.EndPoint local_end) [0x00000] in <filename unknown>:0
  at Mono.WebServer.XSPWebSource.CreateSocket () [0x00000] in <filename unknown>:0
  at Mono.WebServer.ApplicationServer.Start (Boolean bgThread, Int32 backlog) [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) Mono.WebServer.ApplicationServer:Start (bool,int)
  at Mono.WebServer.XSP.Server.DebugMain (System.String[] args, Boolean root, IApplicationHost ext_apphost, Boolean quiet) [0x00000] in <filename unknown>:0
root@servername:/var/www/mvctest/public_html#

What's wrong with xsp? what is a right way to deploy a mono application? how am I supposed to set any other configs?

1

It can mean three things check all and make sure none of them is true your problem will be gone

  1. xsp was already running and you tried to run it again.
  2. The directory is root directory of another server like apache etc.
  3. xsp can not find the required assemblies in the mono path , which means during compiling the mono prefix you gave was wrong.

Just a Suggestion

Another sugestion for you if possible upgrade to ubuntu 14.04 and get all these mono packages already build for you, i personally tried mvc 3 and mvc 4 and even the AspInfoMvc application that is given in the articles that you have mentioned, mono and asp.net works like a charm on 14.04 and auto-hosting also works great with some minor issues which will be fixed soon i hope.

1

i have same problem xsp4 insists on running on port 8080 and i have tomcat running there. kill some other server (oracle, tomcat.. etc) that you have running on 8080 and it shall run.

i really wish to get to know how to explain to xsp to run using different port within monodevelop. from command line is easy: xsp4 -port xxxx but default configs mean nothing to monodevelop ide, it has its own mind

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.