1

I'm having trouble installing emacs24 from the repository ppa:cassou/emacs because of an error in gforth.el. The problem is with a known-bug in gforth.el failing on a byte-compile. I'm currently not able to install anything else with apt. There's no bug on the related launchpad site either. I'm guessing apt noticed I have gforth installed and tried to install the matching emacs mode for it, rather than this being a bug all installations run into.

I have a version of gforth.el on a non-Ubuntu machine that works (just removed the byte compile call), but I'm don't know much about the inner-workings of apt to be able to replace the one provided with this new gforth.el.

From the error message below, would anyone know how to have apt use this file instead of the one provided?

Attempts so far

I've found gforth.el at /usr/share/emacs24/site-lisp/gforth/gforth.el and /usr/share/emacs/site-lisp/gforth/gforth.el. I've replaced both with the working version of the file, but the error message remains the same.

Error message

% sudo apt-get install emacs24
Reading package lists... Done
Building dependency tree       
Reading state information... Done
emacs24 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up emacs24 (24.3+1-2~ppa1~saucy1) ...
Install dictionaries-common for emacs24
install/dictionaries-common: Already byte-compiled for emacs24. Skipping ...
Install gforth for emacs24
install/gforth: Byte-compiling for emacsen flavour emacs24

In toplevel form:
gforth.el:734:18:Error: Don't know how to compile nil
gforth.el:734:18:Error: Don't know how to compile nil
gforth.el:734:18:Error: Don't know how to compile nil
gforth.el:734:18:Error: Don't know how to compile nil
gforth.el:734:18:Error: Don't know how to compile nil
ERROR: install script from gforth package failed
dpkg: error processing emacs24 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 emacs24
E: Sub-process /usr/bin/dpkg returned an error code (1)
2

I think you can temporarily solve the problem by commenting (removing) the following lines in /usr/share/emacs(24)/site-lisp/gforth/gforth.el:

(eval-when-compile
  (byte-compile 'forth-set-word-properties)
  (byte-compile 'forth-next-known-forth-word)
  (byte-compile 'forth-update-properties)
  (byte-compile 'forth-delete-properties)
  (byte-compile 'forth-get-regexp-branch))

I have solved this problem by using this method.

| improve this answer | |
0

I uninstalled the (3) packages with gforth in their name and called "sudo apt-get install -f".

(This can be a workaround and is no solution if you need gforth.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.