I know this has been asked multiple times before, but most of these threads don't have an answer. I tried user62664's solution here and ran sudo update-grub successfully, but nothing changed. This happens whether I type sudo reboot or sudo shutdown -h now. Here is what it looks like when it hangs. There are no error messages, everything shows up with '[OK]', and then:

* Deconfiguring network interfaces...          [OK]
* Deactivating swap...                         [OK]
* Unmounting local filesystems...              [OK]
* Will now restart
[ 1306.738916] mei_me 0000:00:16.0: stop
[ 1306.739745] reboot: Restarting system

This seems like a very common problem, yet there are very few answers and they don't seem to help in my case. Does this mean there is no one solution? In which case, where should I check to check to find out the root cause?

  • 2
    Try options -H, -P with the shutdown command. Preserve symbols' register.
    – Danatela
    Mar 11, 2014 at 3:23
  • It worked! If there is a similar solution for restart, I would be glad to pick your answer.
    – biohazard
    Mar 11, 2014 at 3:53
  • You mean, reboot? It is only for rebooting computer AFAIK. And it should. I cannot find any reason to shut down computer with reboot command.
    – Danatela
    Mar 11, 2014 at 3:56
  • 1
    Sorry, yes, I meant reboot. What I meant in the OP was that the system hangs in both cases, whether I use reboot or shutdown.
    – biohazard
    Mar 11, 2014 at 4:04
  • Try shutdown -r or init 6.
    – Danatela
    Mar 11, 2014 at 4:06

3 Answers 3


From the man shutdown:

       -r     Requests  that  the system be rebooted after it has been brought

       -h     Requests that the system be either halted or powered  off  after
              it has been brought down, with the choice as to which left up to
              the system.

       -H     Requests that the system be halted after  it  has  been  brought

       -P     Requests  that  the  system  be  powered  off  after it has been
              brought down.

As you can see, options -H and -P will poweroff your system. And sudo reboot will only reboot your computer, because it is so designed.

For rebooting your system wishout hanging up I can recommend sudo shutdown -r and sudo init 6. 【⬅This did not work out for me @biohazard】

  • Yes, my problem is that the reboot doesn't actually reboot, it stays frozen as described above. Thank you for solving my problem with shutdown, though. :)
    – biohazard
    Mar 11, 2014 at 4:01
  • Update: answer was edited to include sudo shutdown -r and sudo init 6. sudo shutdown -r hangs;
    – biohazard
    Mar 11, 2014 at 4:55
  • and unfortunately, sudo init 6 hangs too...
    – biohazard
    Mar 11, 2014 at 5:00
  • May be the problem is inside your BIOS. Try to update it…
    – Danatela
    Mar 11, 2014 at 5:03
  • Thanks. Well, at least I am able to shutdown using -HP now, so it's already better than before :)
    – biohazard
    Mar 11, 2014 at 5:05

Passing a reboot= parameter to the kernel can solve this issue, no matter which shutdown command is used.

See http://linux.koolsolutions.com/2009/08/04/howto-fix-linux-hangfreeze-during-reboots-and-restarts/ for more details.

In my case, reboot=pci fixed the problem for a Dell Optiplex 790.

  • This seems to be the only thing that helped but I did change so many other things so not sure but this was one of the changes I made. I initially had reboot=bios
    – NelsonGon
    Sep 13, 2019 at 12:03

When you make shutdown press super+F1 you will see the problem if it is like the following :

Buffer I/O error on device fd0 logical Block 0

you must then go to BIOS and stop the floppy drive !

if it is something else just say at add comment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.