In Ubuntu 11.04, files in /home/user/Desktop appear as icons on the desktop. It seems that they do not under GNOME 3 using GNOME Shell (for example on Fedora 15). How do I configure that?

Update: They do appear by default in 11.10, under both Unity shell and GNOME shell.


4 Answers 4


It can be reversed in gnome3 so if this is implemented the same should be true.

Where are my icons on the desktop?

They are gone, it’s by design. But you can reenable them with:

gsettings set org.gnome.desktop.background show-desktop-icons true

and starting nautilus (if it’s not already running). (Thanks to bronte for the information)


  • Thanks for note about (re)starting Nautilus, I needed it :-).
    – pevik
    Nov 11, 2015 at 12:17
  • Also works in Fedora. Oct 11, 2017 at 20:48
  • the desktop icons is removed completely from gnome 3.28 (source) . :(( Jul 16, 2018 at 18:45

The easiest way to enable desktop icons is to use Gnome Tweak Tool. Run sudo apt-get install gnome-tweak-tool, then launch Gnome Tweak Tool from the Gnome Shell menu. It will be called Advanced Settings.

enter image description here

Then, click on the Desktop button. Enable the option that says "Have file manager handle the desktop. Now, any files placed in the Desktop folder inside your home folder should appear on ther desktop.

  • 3
    I can't find this option in my gnome-tweak-tool, 3.34.0-4, is it gone or am I just missing it?
    – nmr
    Jan 9, 2021 at 17:44

Run this command in your terminal (Applications > Accessories > Terminal):

# show files on desktop
gsettings set org.gnome.desktop.background show-desktop-icons true

# show shares on desktop
gsettings set org.gnome.nautilus.desktop volumes-visible true

# restart nautilus
nautilus -q
  • 1
    The nautilus -q command just quits nautilus. So afterwards, press Alt+F2, enter nautilus and hit enter to start it again, at which point the desktop icons will become visible (again).
    – tanius
    Sep 14, 2013 at 13:50

Unfortunately, Gnome 3.28 has removed the option to put "desktop icons" :(

I will quote the solution

For an immediate, short-term solution, users can install the nemo-desktop file manager and set it up to autostart on login. (Read directions for that here.) Desktop icons are an active part of the Cinnamon user experience. As a result, nemo-desktop actually provides a more feature-rich desktop than Files does today.

  • You might wish to edit your answer to include information regarding the extension prototype
    – Elder Geek
    Jul 16, 2018 at 21:01
  • @ElderGeek Thanks for the suggest. To be honest I didn't try the solution myself, I just quoted it from fedoramagazie.org because the point is not covered in the question, however I will make the post wiki to allow anyone to edit it Jul 16, 2018 at 22:01
  • Uhm, I am running GNOME 3.28 right here and now and that option does evidently exist, although "hidden" inside the Tweaks application. This is on Ubuntu 18.04 with vanilla-gnome-desktop package installed, by the way. Oct 23, 2019 at 20:41
  • @0xC0000022L I can't find the option inside the tweaks app, any idea where it is so I can look again?
    – nmr
    Jan 9, 2021 at 17:49
  • @nmr what version of Ubuntu then? I am pretty much sticking to LTS versions, so at the time of my comment I was likely using 18.04. Jan 9, 2021 at 21:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy