19

I'm currently running GNOME (GNOME Shell 3.10.4; Compiz) on ubuntu.

Alt+Tab does the expected (and "correct") behavior of showing the task switcher, enabling to switch between current open applications.

However, it groups multiple "instances" of the same application (example, gnome-terminal) and requires extra key presses to be able to switch between the instances.


Is there a way to disable the grouping behavior? I've looked around in ccsm and was unable to find anything of relevance.

Any hints you share would be highly appreciated!

0

3 Answers 3

28

I hate the grouping windows function. Anti-programmer. I don't want to remember which window should I press Alt+Tab and which window should I press Alt+`.

Just one combo-key: Alt+Tab for all the windows, all the time!!

So here is the solution for Ubuntu GNOME:

  1. Open dconf-editor.
  2. Go to org/gnome/desktop/wm/keybindings.
  3. Move the value 'Tab' from switch-applications to switch-windows.

Done.

Refer to: Mad Physicist's answer to the same question on Super User

4
  • In my case it meant moving '<Alt>Tab' but this was definitely a simple solution. Worked well on Ubuntu 17.10. Dec 18, 2017 at 10:31
  • 2
    Should be the excepted answer, as it does not need any additional tool. Thx! Jan 16, 2018 at 12:07
  • 1
    This is THE answer.
    – nilsmagnus
    Jan 29, 2018 at 20:57
  • mind that after removing all these unecessary compiz components you'll have to touch and save again the settings in the dconf editor. Sep 2, 2019 at 15:17
10
+150

The normal behavior doesn't require extra key presses to be able to to switch between the instances. When you get to an application that has multiple instances just keep a while the Alt key pressed (maximum 2 seconds) and you will see that after you can switch between instances also using the same shortcut: Alt+Tab. Just don't take your finger from the Alt key.

Anyway, if you want more, the behavior about you asked can be obtained using CompizConfig Settings Manager (you said that you have it installed). After you open it, first enable Application Switcher:

CCSM - Application Switcher

Second, go inside to Application Switcher, select General tab and play a little with those options until you get what you wish. Personally, I made the following selections:

CCSM - Application Switcher - General tab

And the result is:

Application Switcher

5
  • 1
    This does not work, both the Gnome switcher and Compiz task switcher overlap.
    – Jan M.
    Sep 7, 2016 at 11:32
  • How to increase number of applications shown at a time. I've a widescreen monitor and it only shows 3-4 icons at a time leaving empty space to left/right of switcher.
    – Ejaz
    Mar 27, 2017 at 19:13
  • You can show all applications by pressing the "Super" key. Jan 25, 2018 at 8:58
  • Does not work . Apr 12, 2018 at 6:27
  • @JanM. "This does not work, both the Gnome switcher and Compiz task switcher overlap" If you get overlapping application switchers, you have to disable the other one. For example, in CCSM, go to "Desktop > Ubuntu Unity Plugin > Switcher" and disable the <Alt>Tab keybinding.
    – wisbucky
    Jul 2, 2018 at 21:18
4

In my case, I disabled "Application Switcher" and enabled "Shift Switcher" and retained the default options. The windows are not grouped anymore and you get a 'fancy' switcher.

In the screenshot below, the multiple Firefox windows are not grouped together.

enter image description here


For this to work, you will have to install compiz-config settings manager and its plugins. Run this command on the terminal.

sudo apt install compizconfig-settings-manager compiz-plugins compiz-plugins-extra

Once they are installed, launch compiz config settings manager and go the section 'Window Management'. Thst's where you find both the "Application Switcher" and "Shift Switcher" options.

See screenshot:

enter image description here

2
  • at least explain you answer that what is "Application Switcher" and "Shift Switcher", what are the steps to achieve this, how to disabled "Application Switcher" and enabled "Shift Switcher". Apr 12, 2018 at 6:04
  • @RayVaniya I have included more instructions on how to disabled "Application Switcher" and enabled "Shift Switcher".
    – Parto
    Apr 12, 2018 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.