2

I just updated to 13.10 from 12.10. On restarting, I was completely unable to use my keyboard or mouse through USB. I have no PS/2 devices to use. Also, it said that I had been disconnected from my network even though I did not do anything to disconnect it myself. My network card is connected through PCIe x1.

The USB worked in 12.10 and 12.04 and also works in the BIOS and before loading into the kernel, working when you hold shift to test RAM or go into recovery mode.

The kernel is by default 3.11.0-18. Reverting to 3.11.0-15 gives the same issue. Booting into either recovery modes lets you load up the kernel but when the menu appears to start dpkg or other options such as networking the keyboard again fails to work.

Tested with Tesoro Durandal G1NL, Cooler Master Storm Spawn, and a Dell keyboard and Targus mouse of which I am unsure of the exact models, although they were not recently made.

Also of note is that it is not simply a problem with not being able to move the cursor. There is no cursor at all. Ubuntu boots into a black screen, on which a cursor appears. The cursor flickers and then disappears. It then boots into the Unity desktop, with no cursor.

Please help.

  • Same here. I am lucky tho i have old version of kernel and keyboard and mice works with 3.8.0.37 as far as i remember. Was trying to follow few instructions around but no luck. – user261026 Mar 25 '14 at 6:46
  • I have the exact same problem as Konveyorbelt. The only difference is that I've always used 13.10 on my computer and it has normally worked fine. After a week of the computer being off, I turned it on with the message that the BIOS was corrupt and that the system was being reset from the backup BIOS. After that it rebooted with the problem. So maybe it's do with a specific BIOS setting particular to 13.10? Any ideas anyone? – Kashif Apr 23 '14 at 12:30
0

@Konveyorbelt - I have just found a solution that worked for me here: https://unix.stackexchange.com/questions/72625/why-is-usb-not-working-in-linux-when-it-works-in-uefi-bios

Check the BIOS settings - there should be something called IOMMU controller which is disabled by default - When I clicked enable, saved settings and restarted the computer the USB and network functionality were completely restored. Hope it works for you.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.