I got this error while booting

'mount: error while loading shared libraries: libudev.so.0 : no such file or directory' 

Then i followed this

I Booted into recovery mode and opened terminal and installed libudev0 using
apt-get install libudev0

It says its already installed

Even i linked libudev0 and libudev1 as mentioned here But no gain :(

EDIT: Output of locate -e libudev.so.0

  • Please edit your question and post the output of locate -e libudev.so.0 – terdon Mar 9 '14 at 16:34
  • @terdon Posted the output of locate -e libudev.so.0 – vikneshwar Mar 9 '14 at 16:45
  • Are you running a 32 or 64bit system? – terdon Mar 9 '14 at 16:57

I am guessing that you are running a 64bit system. If so, this dirty hack should work:

sudo ln -s /lib/x86_64-linux-gnu/libudev.so.0.13.0 /lib/x86_64-linux-gnu/libudev.so.0

That will crate a link named libudev.so.0 that points to /lib/x86_64-linux-gnu/libudev.so.0.13.0.

  • gives error. ln:failed to create symbolic link. '/lib/x86_64-linux-gnu/libudev.so.0.13.0 ' : File exists – vikneshwar Mar 9 '14 at 17:16
  • @viks did you copy the exact command? It sounds like you ran sudo ln -s /lib/x86_64-linux-gnu/libudev.so.0.13.0 /lib/x86_64-linux-gnu/ instead. – terdon Mar 9 '14 at 17:19
  • ya i used the exact command , thanks for your help , used -f flag with the command and it worked – vikneshwar Mar 9 '14 at 17:26

i had the same problem on ubuntu 12.04 x64, solved it fast first remounting with

sudo mount -o remount, rw /

then locating the libudev.so.0

locate -e libudev.so.0

then doin the "dirty trick"

sudo ln -s /lib/x86_64-linux-gnu/libudev.so.0.13.0 /lib/x86_64-linux-gnu/libudev.so.0

worked perfectly to me, thanx Terdon!

  • Welcome to AU! Please don't post "thank you" messages. The answer section should be reserved for, well… answers. Once you have enough reputation you can vote for other answers, that you find helpful or worthwhile. – David Foerster Jul 10 '15 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.