3

I have recently installed Ubuntu 13.10 64-bit.

It was, by default, using the Nouveau display driver, however, this caused suspend to fail. I installed a proprietary driver which resolved that issue but created an ugly low res boot screen.

How can I fix it?

2

This is the solution that worked for me. (for those who have this common issue)

Run in Terminal

  1. sudo apt-get install v86d

  2. gksu gedit /etc/default/grub

  3. Replace Line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

    New Line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1920x1080-24,mtrr=3,scroll=ywrap"

  4. Replace Line: #GRUB_GFXMODE=640x480

    New Line: #GRUB_GFXMODE=1920x1080

  5. Save & Close

  6. gksu gedit /etc/initramfs-tools/modules

  7. Add Line: uvesafb mode_option=1920x1080-24 mtrr=3 scroll=ywrap

  8. Save & Close

  9. sudo update-grub2

  10. sudo update-initramfs -u

  • In #8, should you still include the "options" keyword before the line in the uvesafb.conf file? From Archlinux: wiki.archlinux.org/index.php/Uvesafb#Configure_uvesafb – elika kohen Oct 15 '15 at 22:01
  • @elikakohen It works without "options" in the modules file. So, no, options is apparently only for uvesafb.conf. – chappjc Oct 20 '15 at 22:49
  • @pst007x so ... I ended up hacking my 9800GT with a custom vesa mode, (in exchange the 1600x1200 setting) -- AND, I also managed to get uvesafb to work. I decided to mod my video card BIOS since another card was already on the way. Thanks! – elika kohen Oct 21 '15 at 14:58
  • Does not work for me with NVidia drivers in Linux Mint 18.1. Resolution is fine with Noveau drivers however. Any other solution? – Aleksey Kontsevich Jan 2 '17 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.