0

I have been tinkering around because I find that Ubuntu 13.10 (which I have as dual boot on my Asus laptop) get my computer a little hot and I get some crashing issues sometimes when watching videos, and more crashes when using slimboat.

Reading around a bit, I (wisely or otherwise) installed fglrx, and then I went into System Settings > Software Updates and in one of the tabs there selected "proprietary driver fglrx update". On rebooting my laptop into Ubuntu, I hear the login sound, but get a black screen.

Since I cannot get into System Settings now to change the graphics card driver back, what can I do?

My graphics card is an ATI Mobility Radeon HD 5470 1 GB. My laptop is 86_64 bit.

EDIT: I looked at the page that gives advice about how to fix the problem of booting to a black screen. I installed Ubuntu a few weeks ago successfully, and have been using it just fine with the exception of some crashing with video files and browsers, as explained above. So the advice for a new install doesn't apply, and grub is working just fine so the dual boot advise doesn't apply either.

I did follow the advise about ATI Radeon drivers:

If your graphics card is ATI, follow these steps:

    In the GRUB menu at startup, press "e"; then
    Use the arrow keys to replace quiet splash with radeon.modeset=0.
    Then press the Ctrl+x key combination to boot.

This did not work either (and I also tried "nomodeset"). Although I did get the purple screen straight out of grub (which I wasn't getting), only to go black before the login screen and the login sound.

The issue here is that I messed around with the graphics driver, and would like to be able to get in long enough to change my settings as explained in my opening 3 paragraphs.

2

1. Open a text-only virtual console by using the keyboard shortcut Ctrl + Alt + F3.

2. At the login: prompt type your username and press Enter.

3. At the Password: prompt type your user password and press Enter.

4. Now you're logged in to a text-only console where you can change your graphics driver from whatever you have now (fglrx-updates???) back to whatever driver you had that was working before (for example, fglrx if that's what driver you were using that was working before). "Reading around a bit, I (wisely or otherwise) installed fglrx, and then I went into System Settings > Software Updates and in one of the tabs there selected proprietary driver fglrx update."

If you can't get into a text only console by pressing Ctrl+Alt+F3 you need to boot into recovery mode.

Immediately after the BIOS/UEFI splash screen during boot, with BIOS, quickly press and hold the Shift key, which will bring up the GNU GRUB menu. (If you see the Ubuntu logo, you've missed the point where you can enter the GRUB menu.) With UEFI press (perhaps several times) the Esc key to get to the GRUB menu. Sometimes the manufacturer's splash screen is a part of the Windows bootloader, so when you power up the machine it goes straight to the GRUB screen, and then pressing Shift is unnecessary.

GNU GRUB menu

Press the down arrow key until you select the 2nd entry from the top (the one with the recovery mode in the description) and then press Enter.

Now you should see this recovery menu:

recovery menu

Using the arrow keys scroll down to network and then press Enter.

Using the arrow keys scroll down to root and then press Enter.

You should now see a root prompt, something like this:

root@ubuntu:~#

At this stage you should have a read-only filesystem. You have to remount it with write permissions:

mount -rw -o remount /

Now uninstall the current graphics drivers and then reinstall the one you had before that worked.

sudo apt-get remove fglrx-updates

5. Reboot the system by running the command: sudo reboot

6. Now you have gone back to the graphics driver you had originally, whatever Ubuntu 13.10 installed by default. Try it for a while and test if it works. Afterwards you can decide whether or not to try to install the proprietary fglrx driver.

  • 1
    When you get to the blank screen and it stops, try pressing Ctrl+Alt+F1 from there. Also there are four fglrx updates drivers: fglrx-updates, fglrx-updates-dev, fglrx-updates:i386, and fglrx-updates-dev:i386 and I don't know which one of these four drivers you now have installed (which is the one to uninstall before you go back to fglrx). – karel Mar 9 '14 at 3:44
  • 1
    Correct error in comment #2. In Ubuntu 13.10 there are only two fglrx-updates packages: fglrx-updates and fglrx-updates-dev. Also, before/if you try to reinstall the proprietary graphics driver, search in the Dash for Additional Drivers, click the Additional Drivers icon and the Additional Drivers window will pop up. This is a graphical application that has additional helpful features in it, such as recommending which driver to choose. – karel Mar 9 '14 at 5:32
  • 1
    "Things are a little hot with the Xorg driver" is worrisome. Take a look at this answer: askubuntu.com/questions/317150/… for information about how to use Psensor to monitor your CPU temperatures to check if your computer is ever overheating. – karel Mar 10 '14 at 1:32
  • 1
    That could also explain why fglrx isn't working. Maybe there's a lot of dust in the aluminum cooling block inside your laptop case. It wouldn't cost much to have a computer technician open the laptop and clean out the dust. – karel Mar 10 '14 at 2:10
  • 1
    There's a mute sound on/off button in the lower right-hand corner of VLC that looks like a little line drawing of a speaker. Click on it and the volume color changes back and forth from green/orange to gray. – karel Mar 10 '14 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.