3

I wanted to modify my mount options for my NTFS external HDD so that I can execute programs on it. I added the following line to my fstab accordingly:

UUID=CE665A3F665A290B  /media/Josh  ntfs-3g defaults,users,nofail 0 0

But when I plug in my external and I get this error:

Error mounting: mount exited with exit code 1: helper failed with:
Error opening '/dev/sdb1': Permission denied
Failed to mount '/dev/sdb1': Permission denied
Please check '/dev/sdb1' and the ntfs-3g binary permissions, and the mounting user ID. More explanation is provided at http://tuxera.com/community/ntfs-3g-faq/#unprivileged.

Soo I go to the URL provided. It says:

Unprivileged block device mounts work only if all the below requirements are met:

  1. ntfs-3g is compiled with integrated FUSE support
  2. the ntfs-3g binary is at least version 1.2506
  3. the ntfs-3g binary is set to setuid-root
  4. the user has access right to the volume
  5. the user has access right to the mount point

I believe I have all 5 requirements met (though obviously not, since I'm getting that error). Anyone have some tips? In particular, I have:

  1. ntfs-3g 2014.2.15 integrated FUSE 27
  2. ntfs-3g 2014.2.15 integrated FUSE 27
  3. -rwsr-xr-x 1 root root 504887 Mar 8 12:06 /bin/ntfs-3g*
  4. brw-rw---- 1 root disk 8, 17 Mar 8 16:43 /dev/sdb1 (my user is in the "disk" group)
  5. drwxrwxrwx 2 josh josh 4096 Mar 8 12:42 Josh/

Been struggling with this for hours. This link has been the most helpful so far, but notably the last post has my same question and is unanswered.

Thanks!

  • Where do you see that error? In dmesg? Are you running any mount commands or is this happening automatically when you pluf the drive in? – terdon Mar 8 '14 at 21:58
  • I get a pop-up with that error. This happens automatically when I plug the drive in, I'm not running any commands at all :( – jwayne Mar 8 '14 at 23:10
  • The message is shown when you plug it, but who throws the message? GNOME? Nautilus? Unity? Does /media/Josh exist? What are the permissions? Add the output of just running ntfs-3g in the terminal. – Braiam Mar 8 '14 at 23:18
  • Do you get the same error if you change ntfs-36 to ntfs in the fstab? I don't think that would give that error but it's worth a shot. Also, please show the output of ls -ld /media /media/Josh to make sure that both directories have the right permissions. – terdon Mar 8 '14 at 23:18
  • I got the same error. ls -ld /media/Josh: (drwxrwxrwx 2 josh josh 4096 Mar 8 12:42 Josh/) ls -ld /media: (drwxr-xr-x 3 root root 4096 Mar 8 18:19 /media) – jwayne Mar 8 '14 at 23:20
0

Found an answer that lets me not edit my fstab to get what I want. Since my disk gets automounted, I added a rule to my udev that told the automount to do something special upon plug-in (that I don't really understand). But now my disk gets automounted with all files executable. I created a file /etc/udev/rules.d/99-usb-disks.rules and added:

ENV{ID_FS_TYPE}=="ntfs", ENV{ID_FS_TYPE}="ntfs-3g"

Source: http://ubuntuforums.org/showthread.php?t=1914416&p=11636662#post11636662

Still haven't found a way to get rid of my permissions error when I do use my fstab mod, though.

Thanks terdon for the help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.