0

I installed eclipse and took help with some links and then I linked it with /usr/bin/eclipse but I am getting error that :-

bash: /usr/bin/eclipse: Permission denied

I tried this command ls -l /usr/bin/eclipse and got below given result.

lrwxrwxrwx 1 root root 53 Mar  8 20:36 /usr/bin/eclipse -> /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse

So can someone suggest any solution, why eclipse is not running?

  • And if you run /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse directly instead of its symlink? Also, what is the output of ls -l /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse ? – janos Mar 8 '14 at 15:38
  • Now there is one more error I had Installed the Android adt bundle so now eclipse has be initialized but on startup it is giving an error that could not find SDK folder '/home/gaurav/kubusoft/adt-bundle-linux-x86_64-20131030/sdk/'. Is it because I had also copied the sdk along with the eclipse in the same adt-bundle-linux-x86_64-20131030 folder in my /opt directory. And if so then how can I edit it. – Gaurav A Dubey Mar 8 '14 at 15:50
1

It seems the file you're trying to execute is not executable. Try this:

chmod +x /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse

If you installed Eclipse there as superuser, then run it with sudo:

sudo chmod +x /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse

After this you should be able launch Eclipse as either /usr/bin/eclipse or /opt/adt-bundle-linux-x86_64-20131030/eclipse/eclipse.

  • Thanks janos that worked :) also thanks to Avinash . Can you Please tell me what was the error – Gaurav A Dubey Mar 8 '14 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.