Host OS: Ubuntu 12.04.4 LTS

Ubuntu Touch Device: Nexus4 Running Ubuntu 13.10

My dev environment is QtCreator with the ubuntu-sdk plugin

I'm trying to deploy the QML / C++ sample app (the one created by the QtCreator Application/Qt Quick2 Application) on the phone. The phone is connected to the development host via a usb cable

I successfully run the command: Build->Ubuntu->Build and Install Application on device

On the phone I got the application installed under /opt

├── bin
│   └── qtquick-01
└── qml
    └── qtquick-01
        └── main.qml

unfortunately I cannot figure out how to run it on the device I tried several stuff, including creating a .desktop file hoping to got an icon and be able to start the app from the phone's touch interface. Maybe I'm just configuring the .desktop file the wrong way. Is there some link you can suggest to understand how to write it properly and where to place it?

From an ssh shell I tried running directly the binary or the qml file (with qmlscene) Apparently I do not got an error, but I cannot see anything on the phone screen.

I read online that the app is started "minimized" by default and I can maximize it form the App Lens, but I cannot see it there either.

1 Answer 1


Further trial-and-error brought me to a solution.

  • created a .desktop file following the instruction at Ubuntu SDK Alpha
  • Placed the desktop file under /opt/qtquick-01 (the root of the installed app)
  • logged via ssh on the phone as phablet user, not ROOT (that was my main mistake I guess)
  • run the command: qmlscene --desktop_file_hint=/opt/qtquick-01/qtquick-01.desktop qml/qtquick-01/main.qml

Still, I cannot get the app icon to be displayed with the installed apps in the app lens.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .