3

So I am having the exact issue as was happening in this question here

I have also installed a VPN connection via NetworkManager and getting the exact same stack trace. I've looked at /etc/nsswitch.conf but did not see any wins entries. Mine is as follows:

passwd:         compat
group:          compat
shadow:         compat
hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
networks:       files
protocols:      db files
services:       db files
ethers:         db files
rpc:            db files
netgroup:       nis

I too am getting: /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring... but I have libgcrypt11=1.5.0-3ubuntu3 so not sure if this still has the bug mentioned in 2.2 or if it has been fixed.

I noticed that the poster of the other question was able to remove some configs and that made it work but I do not know what configs to remove. Wondering if anyone knows or if anyone has fixed this before?

My logs for connection are as follows:

Mar  8 21:04:27  whoopsie[1046]: last message repeated 2 times
Mar  8 21:04:27 aeries NetworkManager[777]: <info> Starting VPN service 'pptp'...
Mar  8 21:04:27 aeries NetworkManager[777]: <info> VPN service 'pptp' started (org.freedesktop.NetworkManager.pptp), PID 17713
Mar  8 21:04:27 aeries NetworkManager[777]: <info> VPN service 'pptp' appeared; activating connections
Mar  8 21:04:27 aeries NetworkManager[777]: <info> VPN plugin state changed: init (1)
Mar  8 21:04:28 aeries NetworkManager[777]: <info> VPN plugin state changed: starting (3)
Mar  8 21:04:28 aeries NetworkManager[777]: <info> VPN connection 'YesVPN' (Connect) reply received.
Mar  8 21:04:28 aeries pppd[17717]: Plugin /usr/lib/pppd/2.4.5/nm-pptp-pppd-plugin.so loaded.
Mar  8 21:04:28 aeries pppd[17717]: pppd 2.4.5 started by root, uid 0
Mar  8 21:04:28 aeries pppd[17717]: Using interface ppp0
Mar  8 21:04:28 aeries pppd[17717]: Connect: ppp0 <--> /dev/pts/7
Mar  8 21:04:28 aeries pptp[17720]: nm-pptp-service-17713 log[main:pptp.c:314]: The synchronous pptp option is NOT activated
Mar  8 21:04:28 aeries NetworkManager[777]:    SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Mar  8 21:04:28 aeries NetworkManager[777]:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Mar  8 21:04:28 aeries NetworkManager[777]: <warn> /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring...
Mar  8 21:04:28 aeries whoopsie[1046]: online
Mar  8 21:04:29 aeries pptp[17733]: nm-pptp-service-17713 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'
Mar  8 21:04:29 aeries pptp[17733]: nm-pptp-service-17713 log[ctrlp_disp:pptp_ctrl.c:739]: Received Start Control Connection Reply
Mar  8 21:04:29 aeries pptp[17733]: nm-pptp-service-17713 log[ctrlp_disp:pptp_ctrl.c:773]: Client connection established.
Mar  8 21:04:29 aeries whoopsie[1046]: online
Mar  8 21:04:30 aeries pptp[17733]: nm-pptp-service-17713 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'
Mar  8 21:04:30 aeries pptp[17733]: nm-pptp-service-17713 log[ctrlp_disp:pptp_ctrl.c:858]: Received Outgoing Call Reply.
Mar  8 21:04:30 aeries pptp[17733]: nm-pptp-service-17713 log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call established (call ID 0, peer's call ID 45759).
Mar  8 21:04:59 aeries whoopsie[1046]: online
Mar  8 21:05:00 aeries whoopsie[1046]: online
Mar  8 21:05:08 aeries NetworkManager[777]: <warn> VPN connection 'YesVPN' (IP Config Get) timeout exceeded.
Mar  8 21:05:08 aeries NetworkManager[777]: <info> Policy set 'MERCURY_JJ' (wlan0) as default for IPv4 routing and DNS.
Mar  8 21:05:08 aeries pppd[17717]: Terminating on signal 15
Mar  8 21:05:08 aeries pppd[17717]: Connection terminated.
Mar  8 21:05:08 aeries avahi-daemon[576]: Withdrawing workstation service for ppp0.
Mar  8 21:05:08 aeries NetworkManager[777]:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Mar  8 21:05:08 aeries pppd[17717]: Child process /usr/sbin/pptp 174.139.17.123 --nolaunchpppd --loglevel 0 --logstring nm-pptp-service-17713 (pid 17719) terminated with signal 15
Mar  8 21:05:08 aeries pppd[17717]: Exit.
Mar  8 21:05:08 aeries pptp[17720]: nm-pptp-service-17713 warn[decaps_hdlc:pptp_gre.c:204]: short read (-1): Input/output error
Mar  8 21:05:08 aeries pptp[17720]: nm-pptp-service-17713 warn[decaps_hdlc:pptp_gre.c:216]: pppd may have shutdown, see pppd log
Mar  8 21:05:08 aeries pptp[17733]: nm-pptp-service-17713 log[callmgr_main:pptp_callmgr.c:234]: Closing connection (unhandled)
Mar  8 21:05:08 aeries pptp[17733]: nm-pptp-service-17713 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'
Mar  8 21:05:08 aeries pptp[17733]: nm-pptp-service-17713 log[call_callback:pptp_callmgr.c:79]: Closing connection (call state)
Mar  8 21:05:13 aeries NetworkManager[777]: <info> VPN service 'pptp' disappeared
  • have same issue on 14.04 ... on my previous ubuntu I managed to solve it but now I cannot figure out how ... I tried your below solution but no luck – Postadelmaga Apr 1 '14 at 11:20
  • I just upgrade to 14.04 and pptp client failed. Follow the answer to uncomment the silent and it worked for a while then failed. – raykin May 6 '14 at 8:59
1

After searching the net I found a solution for my pptp vpn connection to work with the network manager by following the steps at http://www.jamescoyle.net/how-to/963-set-up-linux-pptp-client-from-the-terminal

after having this set up manually the GUI network manager just worked fine

Make sure to change the connection profile name in the secrets to PPTP.

Hope this helps others as well

Peter

  • 1
    Welcome to Ask Ubuntu. Thanks for your participation. It is highly recommended not to just give a link to a solution described somewhere else on the net. The rationale is that if that link becomes unreachable your answer becomes useless. So users are encouraged to provide at least an overview of what's involved and then add the link for reference/attribution. – hmayag May 24 '14 at 8:04
0

So I was able to make this work. I've been at it for a few days now looking at every post related to this and specifically to this error:

NetworkManager[777]: <warn> /sys/devices/virtual/net/ppp0: couldn't determine device driver; ignoring
....
(IP Config Get) timeout exceeded

At some point I found an article that suggested to go into /etc/ppp/options and uncomment the silent entry which I did and unfortunately it did nothing. So then I found another article that suggested to do the following, in the Network Manager VPN Configuration options (Network Manager > Configure VPN > Advanced) uncheck everything BUT MSCHAP, MSCHAPv2, Use Point to point encryption (MPPE) which I did but still no change. I just went back and commented out the silent line and then it suddenly connected. Hopefully if you encounter the same issue this will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.