I decided to try out Ubuntu Touch using the ubuntu-emulator to see if I like it. Eventually I will use this to make and test Ubuntu apps.

I ran these commands to install, create and run ubuntu-emulator:

sudo apt-get install ubuntu-emulator
sudo ubuntu-emulator create myinstance
ubuntu-emulator run myinstance

The first two worked fine and when I ran the third, a virtual phone appeared however the virtual screen was blank. I waited and waited, but nothing happened, the screen remained blank/black (on the virtual phone). Then I notice I have to log in terminal. I entered phablet then phablet and logged in fine.

Now I have the terminal logged in and a virtual kernel of the phone but the screen is blank. How can I start the graphics?

Also, once I've got the screen working, can I reduce the window size (it doesn't all fit on one desktop)?

  • 4
    Note that the ARM emulator can take an extremely long time to start, depending on your system. The X86 emulator is not quite ready yet. Even on my i7 3770 with 16GB of RAM, the ARM emulator still took several minutes to come up, and was extremely slow to interact with (to the point of it actually being impossible to use).
    – dobey
    Mar 16 '14 at 16:21
  • I have a quad-core AMD A8 processor and 8GB of RAM, and I waited about 30 minutes for the display to come up. Nothing happened. Mar 21 '14 at 4:52

First of all, currently, the Ubuntu Touch Emulator is only available for Ubuntu 14.04 Trusty Tahr and because of this sudo apt-get install ubuntu-emulator command will work only if you have already upgraded to Ubuntu 14.04 which make the question off-topic at the moment.

Anyway, I will try an answer. One of the minimal requirements for the emulator is that the graphics card to has OpenGL support. To test if your graphics card has OpenGL support or not, you can use the glxinfo command as follow:

glxinfo | grep render

You will understand from the output if your graphics card has OpenGL support or not.

Note: mesa-utils package must to be installed in order to use glxinfo.

Another two things from the minimal requirements:

  • 512MB of RAM dedicated for the emulator
  • 4GB of disk space

Now, if these minimal requirements are met, I'm sure that you can start using Ubuntu Touch emulator with success. Just wait some (maybe several) minutes to come up the graphics.


  • I have 8GB of RAM and well over 100GB of free disk space so that's certainly not an issue. I am running Trusty (though I'm not sure about the OP), so that shouldn't be a problem either. Mar 16 '14 at 16:10
  • @NathanOsman What about OpenGL capable desktop drivers? Mar 16 '14 at 19:05
  • Accordng to glxinfo, I have direct rendering: Yes. Mar 16 '14 at 20:57
  • The problem is with dedicated RAM. By default it only dedicates 512 MB RAM to the emulator.
    – Pavak Paul
    Feb 3 '15 at 10:33

If you use an NVIDIA graphics card ? Check if you are running the X.Org X Server Nouveau display driver. If so, install the proprietary NVIDIA driver from "Software & Updates" an reboot the machine. Hereafter the ubuntu-emulator should running fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.