1

I have GNOME installed on Ubuntu 13.10, and I enables several input methods (Japanese Anthy, Korean Hangeul and Chinese Pinyin) in addition to my English (US) keyboard. I set the shortcut to Ctrl+Space, then Super+Space, then Alt+Shift and multiple other combinations, however, whenever I use these shortcuts to attempt to cycle through my input methods, it only goes to the next one and stops.

For example, if I Ctrl+Space from English (US) to Japanese (Anthy), I cannot press Ctrl+Space to change further. I am stuck at Japanese (Anthy) until I let go of Ctrl+Space and repeat. However, clicking on the input method icon and changing still works for all input methods.

Does anyone know what the problem might be? To clarify again, I am using GNOME's input sources from System Settings.

UPDATE: The latest system updates have solved this problem.

UPDATE2: I have checked and realized that the problem exists in GNOME but not in GNOME Classic.

UPDATE2B: After further experimentation, I have found that the problem sometimes exists and sometimes doesn't exist, and doesn't depend on whether it is in GNOME or GNOME Classic. Logging out and in usually solves the problem.

3

Have you tried reassigning the same shortcut for Previous Source, in an attempt to blank it?

I remembered seeing this problem a few days ago as well, on a 13.10 fresh installation. Didn't have the keyboard option when I installed over a freshly formatted partition.

Later on, I reinstalled Ubuntu entirely due to another unrelated problem, and this time, I was given the option to set my keyboard. Did so, and the shortcut problem was gone.

Looking back upon this, you might want to try reconfiguring your keyboard settings.

sudo dpkg-reconfigure keyboard-configuration
  • Thank you for your answer. I have not assigned the same shortcut for Previous Source, I have assigned Ctrl+Shift+Space. However, you make a valid point and this answer may help other users. Also, dpkg-reconfigure must be run as root. – Davidson Chua Mar 9 '14 at 2:49
  • Ah yeah, my bad, forgot to add sudo. – eccentricSam Mar 9 '14 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.