3

The File & Folders lens and default Applications lens is missing from my dock. How can I get them back?

I attempted the guide here: http://www.webupd8.org/2011/04/how-to-reset-unity-launcher-icons-or.html

All the icons came back except the two missing lenses. unity-place-applications and unity-place-files are both currently installed.

  • 1
    Do you have .desktop files for both in /usr/share/unity/places? Have you tried reinstalling the packaged (sudo apt-get install --reinstall unity-place-files unity-place-applications)? – htorque May 16 '11 at 6:52
  • there is an applications.place file and a files.place file in that location. – gregghz May 16 '11 at 15:13
  • @htorque Your solution worked for me -- maybe make it an answer? – belacqua May 24 '11 at 5:41
7
  • Make sure you have those packages installed:

    unity-lens-applications
    unity-lens-files
    
  • Make sure you have those two files in /usr/share/unity/lenses:

    applications.lens
    files.lens
    
  • If it still doesn't work, try to reinstall the two packages:

    sudo apt-get purge unity-lens-applications unity-lens-files
    sudo apt-get install unity-lens-applications unity-lens-files
    
  • If it still doesn't work, I suggest reporting a bug report:

    ubuntu-bug unity # if unity is the wrong package, others will fix it
    
  • I'm not sure how common this problem is anymore, but I just did a bare bones install of Ubuntu 12.10 and couldn't find anything in the Dash. It seems the unity-place-applications and unity-place-files packages have been replaced by unity-lens-applications and unity-lens-files, respectively - just in case anyone else comes across this. – David Kennedy Apr 21 '13 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.