0

Unable to run .py file in Ubuntu 13.10 server. It returns this error:

Traceback (most recent call last):
File "events_send.py", line 2, in <module> import pika
ImportError: No module named pika
  • Have you tried installing the python-pika package? – Bruno Pereira Mar 7 '14 at 12:05
1

your missing the pika package Before you installing the pika ,install python-pip and git-core, since the pika installation depends on these packages. Then install pika Packages

sudo apt-get install python-pip git-core

sudo pip install pika==0.9.8
| improve this answer | |
  • did that still not working same problem. – Dor Mar 8 '14 at 16:13
0

You have to install python-pika package

sudo apt-get install python-pika

Pika is a pure-Python implementation of the AMQP 0-9-1 protocol that tries to stay fairly independent of the underlying network support library.

| improve this answer | |
  • Did that, nothing, still the same issue. – Dor Mar 8 '14 at 16:19
0

The message indicates a library is missing. Try installing it with pip using this command:

pip install pika

You may also have other dependencies that need to be installed as well, we'll know once the application is started after this library is installed.

| improve this answer | |
  • Tried this also, nothing, still the same error. – Dor Mar 8 '14 at 16:18
-1

This may be a directory permission problem. Check:

/usr/local/lib/python2.7/dist-packages/pika
/usr/local/lib/python2.7/dist-packages/pika-0.9.14.egg-info

(depend on which version of python and pika you use)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.