i tried to install sqlite3 on ubuntu 10.04 by typing:

sudo apt-get install sqlite3

this gave me the message

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

so i tried the "sudo dpkg --configure -a", no error. I tried to install sqlite3 again. This time it showed what updates will be done. So i continued and received this error message (partially translated from greman):

Unpacking substitution for ubuntu-docs ...
dpkg: ../../src/archives.c:763: tarobject: Assertion »r == stab.st_size« not fullfilled 
E: Sub-process /usr/bin/dpkg exited unexpectedly

i hope that some experts in here can help me :)

  • is it possible to delete the /bin/dpkg and download it with wget again, to configure/make/make install it ?
    – buffkit
    May 16 '11 at 1:19
  • If you try something like apt-get install ruby will that fail with the same error? May 16 '11 at 3:47
  • 1
    delete /bin/dpkg? are you crazy? The right way to break the system.
    – enzotib
    May 16 '11 at 7:51
  • @Aleksandr any kind of installation fails
    – buffkit
    May 16 '11 at 9:32

Turns out one package (ubuntu-docs) was in an inconsistant state, which lead to the error message shown above.

I found this post on UbuntuFormus and used

sudo dpkg --force-all -r ubuntu-docs

to force the removal of all ubuntu-docs related package information. apt-get/aptitude purge/remove (even with force) didn't work because of the inconsistant state.

Be cautious when using this command because it might destroy your system

  • The link requires login.
    – nanofarad
    Aug 13 '12 at 17:25

I would start troubleshooting by checking the integrity to your dpkg.

Here are all the dpkg files for Ubuntu 11.04 with docs and directories filtered out:


You you post the checksums of you're files. To get those run:

wget http://biocluster.ucr.edu/~alevchuk/dpkg-1.16.0~ubuntu7-file-list
cat dpkg-1.16.0~ubuntu7-file-list | xargs md5sum > my-dpkg-checksums

Then please post the my-dpkg-checksums file so we can compare the checksums.

Also please post whether your Ubuntu is 32 or 64-bit (e.g. just post the output of uname -r)

  • My system is 64 bit and running above 2 commands doesn't return anything how does it work?
    – wisemonkey
    Oct 19 '11 at 0:46
  • wget downloads a list of files. md5sum check-sums your system files. The commands don't output anything but they produces 2 files: dpkg-1.16.0~ubuntu7-file-list and my-dpkg-checksums Oct 19 '11 at 13:56
  • Sorry not noticing the files, yea Ive those 2 files but is it still helpful as I'm using 11.10 64 bit and I think your list is for 10.04? Thanks
    – wisemonkey
    Oct 19 '11 at 17:51

First off. Do not delete the dpkg binary and try to download it with wget that is a horrible idea.

Second off. Are you using NTFS or an EncryptFs volume? This sounds a lot like:

https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/573696 and or https://bugs.launchpad.net/ubuntu/+source/linux/+bug/524919

The suggestion is to move back to an ext3 file system. More information about the system you are on including the Ubuntu release and the filesystem where these files are being accessed would be helpful.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.