1

I have a printer installed on an ubuntu server (12.04 LTS)

I can print items with no issue, but it always prompts for a username and password, which is super annoying.

I tried everything I could find about it online but nothing seems to remove the prompt.

I set DefaultAuthType to None in /etc/cups/cupsd.conf, still a prompt.

also just read this post:

Cups is always asking for password when printing on a certain printer

but that didn't help either sadly, though for me I only have one printer so I'm baffled on what to do now.

Thanks.

EDIT:

Here is what my CUPS files look like:

printer.conf

# Printer configuration file for CUPS v1.5.3  
# Written by cupsd    # DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<DefaultPrinter Canon_MX310_series>
UUID urn:uuid:5a7453c6-3dc0-3bce-53f1-7584efb6144a
Info Canon MX310 series
Location Living Rm
MakeModel Canon PIXMA MX300 - CUPS+Gutenprint v5.2.8-pre1
DeviceURI usb://Canon/MX310%20series?serial=16BE66&interface=1
State Idle
StateTime 1388353343
Type 12627980
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
AuthInfoRequired none
ErrorPolicy retry-job
Option media-col media-bottom-margin
</Printer>

cupsd.conf

LogLevel warn
MaxLogSize 0
SystemGroup lpadmin
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseLocalProtocols CUPS dnssd
BrowseAddress @LOCAL
DefaultAuthType None
WebInterface Yes
<Location />
  # Allow remote administration...
  Order allow,deny
  Allow all
</Location>
<Location /admin>
  AuthType None
  # Allow remote administration...
  Order allow,deny
  Allow all
</Location>
<Location /admin/conf>
  AuthType None
  Require user @SYSTEM
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow all
</Location>
<Policy default>
  JobPrivateAccess default
  JobPrivateValues default
  SubscriptionPrivateAccess default
  SubscriptionPrivateValues default
  <Limit Create-Job Print-Job Print-URI Validate-Job>
    Order deny,allow
  </Limit>
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit All>
    Order deny, allow
  </Limit>
</Policy>
<Policy authenticated>
  JobPrivateAccess default
  JobPrivateValues default
  SubscriptionPrivateAccess default
  SubscriptionPrivateValues default
  <Limit Create-Job Print-Job Print-URI Validate-Job>
    AuthType Default
    Order deny,allow
  </Limit>
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    AuthType Default
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Cancel-Job CUPS-Authenticate-Job>
    AuthType None
    Require user @OWNER @SYSTEM
    Order deny, allow
  </Limit>
  <Limit All>
    Order deny,allow
  </Limit>
</Policy>
2

Try to change in /etc/cups/printers.conf

AuthInfoRequired none

I have installed hp2015 and don't have problem

<DefaultPrinter hp2015>
UUID urn:uuid:c7c39f9e-7dc7-3a45-7531-fc4222d08420
AuthInfoRequired none
Info hp2015
Location x.x.x.x
MakeModel HP LaserJet p2015 Series pcl3, hpcups 3.13.9
DeviceURI ipp://x.x.x.x:631/printers/hp2015
State Idle
StateTime 1393930474
Type 8425502
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
Option cups-browsed true
</Printer>

and this is my cupsd.conf

LogLevel warn MaxLogSize 0
# Allow remote access Port 631 Listen /var/run/cups/cups.sock
# Share local printers on the local network. Browsing On BrowseLocalProtocols dnssd DefaultAuthType Basic WebInterface Yes
<Location />   # Allow shared printing...   Order allow,deny   Allow
all </Location> <Location /admin> </Location> <Location /admin/conf>  
AuthType Default   Require user @SYSTEM </Location> <Policy default>  
JobPrivateAccess default   JobPrivateValues default  
SubscriptionPrivateAccess default   SubscriptionPrivateValues default 
<Limit Create-Job Print-Job Print-URI Validate-Job>
    Order deny,allow   </Limit>   <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes
Create-Job-Subscription Renew-Subscription Cancel-Subscription
Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job
Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    Require user @OWNER @SYSTEM
    Order deny,allow   </Limit>   <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class
CUPS-Set-Default CUPS-Get-Devices>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow   </Limit>   <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job
Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer
Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer
Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs
CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow   </Limit>   <Limit CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow   </Limit>   <Limit All>
    Order deny,allow   </Limit> </Policy> <Policy authenticated>   JobPrivateAccess default   JobPrivateValues default  
SubscriptionPrivateAccess default   SubscriptionPrivateValues default 
<Limit Create-Job Print-Job Print-URI Validate-Job>
    AuthType Default
    Order deny,allow   </Limit>   <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes
Create-Job-Subscription Renew-Subscription Cancel-Subscription
Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job
Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    AuthType Default
    Require user @OWNER @SYSTEM
    Order deny,allow   </Limit>   <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class
CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow   </Limit>   <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job
Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer
Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer
Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs
CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow   </Limit>   <Limit Cancel-Job CUPS-Authenticate-Job>
    AuthType Default
    Require user @OWNER @SYSTEM
    Order deny,allow   </Limit>   <Limit All>
    Order deny,allow   </Limit> </Policy>

You can check your part of /etc/cups/printers.conf and /etc/cups/cupsd.conf. I don't have problem with authorization when printing.

  • 1
    AuthInfoRequired isn't on there, so I'll try to add that tonight when I have access to my server (its a home server so its not publicly broadcasted) and see if that does it. – Eman Mar 7 '14 at 14:27
  • that didnt work either, I altered my question to include what my config files look like. – Eman Mar 8 '14 at 14:21
  • Try to replase your cups.conf with my. Restart cups and try to print. – 2707974 Mar 8 '14 at 20:13
  • Could you correct your line breaks? – IceFire May 30 '17 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.