I am currently running 12.04 and I can't get Jupiter to install on my computer.

These are the commands I am running to install it:

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter

This is the error I get after updating:

W: Failed to fetch http://ppa.launchpad.net/webupd8team/jupiter/ubuntu/dists/saucy/main/binary-amd64/Packages  404  Not Found

and finally after install jupiter, I get this error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package jupiter

Any ideas on how I can fix this issue? Or can anyone point me in the right direction?

marked as duplicate by wojox, Amith KK, Aditya, mikewhatever, BuZZ-dEE Mar 7 '14 at 21:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I'm trying to install in 12.04 and the commands aren't working properly is the difference. – Sarah Mar 7 '14 at 1:36
  • Post the contents of /etc/apt/sources.list – Stormvirux Mar 7 '14 at 3:08
  • 1
    Jupiter is no longer maintained is it? – wojox Mar 7 '14 at 3:14
  • in the update error its showing saucy meaning your etc/apt/sources.list has errors. I just installed jupiter in precise without any issue – Stormvirux Mar 7 '14 at 3:34
  • Post only the output of lsb_release -sc – Avinash Raj Mar 7 '14 at 4:25

First let's remove the old added repository:

sudo apt-add-repository --remove ppa:webupd8team/jupiter

Now add the correct version:

echo "deb http://ppa.launchpad.net/webupd8team/jupiter/ubuntu precise main " | sudo tee -a /etc/apt/sources.list

echo "deb-src http://ppa.launchpad.net/webupd8team/jupiter/ubuntu precise main" | sudo tee -a /etc/apt/sources.list

Now update:

sudo apt-get update

Its time to install

sudo apt-get install jupiter
  • don't need to remove the PPA.Just change the word saucy to precise inside /etc/apt/sources.list.d/webupd8team-jupiter-saucy.list file.Then update and install jupiter. – Avinash Raj Mar 7 '14 at 5:35
  • I really not sure whether its in sources.list.d or just in sources.list specially the OP didn't post the sources.list file so just to be clean I did so... – Maythux Mar 7 '14 at 5:38
  • i think, ppa should be added in /etc/apt/sources.list.d directory not inside sources.list.I already tried this and it worked. – Avinash Raj Mar 7 '14 at 5:40
  • Yes now It's so but still some PPAs are added to the sources.list just working on the old criteria and i already installed juipter before and i know it's under sources.list.d but as i told you just to be clean – Maythux Mar 7 '14 at 5:41
  • But both will works. – Avinash Raj Mar 7 '14 at 5:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.