I'm having serious problems installing Ubuntu on my Asus Rampage IV Extreme/i7, in fact in any version of Linux at all.

Here are the steps I'm following:

  1. Direct boot Kubuntu 13.10 from DVD - Sometimes installer starts, sometimes not (freeze on Kubuntu logo) - when it starts it installs just fine, after that login screen shows after login freeze while being on "hard drive" icon, however once it started don't know why...
  2. Direct boot Ubuntu 13.10 - freeze and stop reading from CD at install screen (this one with passing dots).
  3. 12.04 - same thing in both cases.
  4. Wubi 12.4 from Windows installed just to do it - install on Windows completes fine, after restart: "To show other install options press ESC now" then shows "0" and freezes.
  5. Recommended by manufacturer 11.4 same thing.
  6. OLE/openSUSE/other RedHat based - "waiting for hardware to initialize" or "starting udev..." before installation, then freezes.

Tried with different combinations of BIOS settings/install options like nomodprobe but nothing worked.

Is system incapable of handling any linux ?

EDIT - Specs:

Intel Core i7 4930K

Kingston HyperX DDR3 4x 8GB 1600 MHz CL9 XMP Beast

GeForce with CUDA GT210 Asus 1GB Silent HDMI & DVI (PCI-E) (DDR3)

WD VelociRaptor 500GB WD5000HHTZ (SATA/600,64MB) x2

Lite-ON DVD /-RW iHAS122-04 SATA

  • Have you tried doing a server install? Or minimal install without using the graphic card drivers? – LnxSlck Mar 6 '14 at 15:44
  • Server install: no, minimal: yes, also freeze in some moment. Will post in few minutes what is with server edition. Linux is important because i have linux license for professional software. In fact any distro/version satisfies me. – pgr Mar 6 '14 at 15:48
  • Try also switching your hard drive or memory, it looks like an hardware issue – LnxSlck Mar 6 '14 at 15:50
  • I hardly doubt it's a hardware issue, Windows works just fine, PC arrived brand new 3 days ago. About server: in any option after pressing "install..." it freeze on blank screen, except nomodprobe+expert however keyboard does not respond = freeze – pgr Mar 6 '14 at 16:08
  • For me it sounds more like UEFI is enabled in the BIOS. Try to disable UEFI and it should all work. If not let us know. – konqui Mar 11 '14 at 10:07

I have a bunch of questions/suggestions for clarification for you and others.

What do you mean by freeze? Sometimes linux could appear to be frozen but actually, it could just be a pci issue where no inputs are being accepts.

What part is freezing?

Have you tried USB installation over DVD installation? What are the steps you used to create the DVD(or USB)?

Here is a similar thread. Seems like you have a nVidia GPU, and it seems like your motherboard does not have an onboard display out. The solution mentioned is to use nomodeset when installing/booting to either liveCD or ubuntu itself. Of course this depends on what kind of freezing issues you are having.

Try to minimize possible hardware issues. I see that you have 2 HDD's attached. Disabling RAID may be worth a shot as well. The thread I linked also mentioned that there could be issues with multiple HDDs and noted it was better to isolate the linux installation on one drive though I do not understand the detailed logic behind that. Additionally, validate that your RAM is stable. Seems like there are hard freezing issues when the RAM is faulty. I see that you have 4 sticks. See what happens when you only use one. Note: Use 64-bit distros. 32-bit has a RAM limit.

I did not see anything about IOMMU settings on this mother but check if you have this. Sometimes keyboard/mouse will not work because of this which may be causing the "freezing". Depending on where it freezes, it may be worth it to try an external mouse/keyboard. Avoid USB 3.0 if possible.

UEFI can also cause complications. Did you boot the installation device in UEFI mode?

I'd suggest adding more details to your post with these questions.

| improve this answer | |
  • Actually I managed to install Linux but reboot is somehow strange so problem is not solved completely. Everything works fine, after reboot I have to wait till system freeze during loading (no response of anything), then Load default Bios, save&exit, works :) – pgr Mar 12 '14 at 13:44

Actually after time it was Linux problem itself. Under Kernel 3.15 rc3 everythings runs fine.

| improve this answer | |

This is caused by RAID please make sure you disable it in the BIOS and then try installing :)

please let me know if it helps

| improve this answer | |
  • Thanks for your reply, i`ll check it within few hours. Can RAID be problematic even when those 2 drives are not running in it (separetely) ? – pgr Mar 10 '14 at 1:05
  • If raid is on in the bios it can do problems. Had that once on my hp laptop it got solved once i disabled raid – Hawk-Tech Mar 10 '14 at 9:27
  • Actually RAID was turned off from the beginning – pgr Mar 12 '14 at 13:41

Try some kernel modificators:


you know what I mean. Play a little with one or some o them. It worked for me.

| improve this answer | |
  • Tried with different combinations – pgr Mar 12 '14 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.