0

Hi guys well i'm new to Ubuntu my first time try to install and set environment stuffs on Ubuntu.

I installed jdk 7 from webupd installer and installed the default setting package. I also installed ant 1.9.3 which should be installed properly.

Firstly I followed the instructions which I got from google search, it said i just need to download the package and extract it and put it anywhere I want. But it turned out when I click the eclipse it just doesn't work. Nothing happened.

So I did a lot of search, I finally followed this blog here

I downloaded eclipse from the official site its a very neat instruction and I compared with many other instructions I got it seems it should work. But after I followed all of those steps I got the message like this: "eclipse" is not installed

I read this, then added the "-vm" and "/path/to/java" thing into the eclipse.ini like this:

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140116-2212
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
/usr/lib/jvm/java-7-oracle/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m

Then I tried to run eclipse from terminal again (with the command: eclipse). Got the error msg like this:

nini@nini-Vostro-3350:~$ eclipse
bash: /usr/bin/eclipse: cannot execute binary file

I totally don't know what happened and have been working on this for the whole day. Is there anyone can help me ? Thank you very much.

  • 1
    I don't really understand. Why didn't you install eclipse with sudo apt-get install eclipse ? Can you cd to /opt/eclipse/ and simply enter eclipse in the terminal ? – Buddyshot Mar 6 '14 at 14:01
0

As of the link to the article you have mentioned in the question, the author shows an example to download 64-bit version of eclipse.

I doubt you are using x86 Ubuntu with a x86_64 JVM. To make sure your Ubuntu is 64 bits, run the following command:

$ uname -i
  • with this command i got: i386 – user255399 Mar 6 '14 at 23:46
  • i also tried the command "uname -mrsn" and got this output: "Linux nini-Vostro-3350 3.11.0-15-generic i686" so i guess it's correct? – user255399 Mar 6 '14 at 23:48
  • i686 that means you have x86 bit machine so try installing 32 bit eclipse – Aatish Sai Mar 7 '14 at 8:58
  • Thanks Aatish the 32-bit does work. sorry it was a stupid question :P but i still don't quite understand how come this cos actually all other apps and my OS are def 64-bit – user255399 Mar 8 '14 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.