13

My Dropbox folder is on another partition on my harddrive and Dropbox loads on start up. But since the separate partition has't been opened yet, Dropbox complains that my Dropbox folder is missing. So Ihave to close Dropbox, make sure my separate partition is mounted, then load Dropbox again.

Is there a way to auto-mount my drive before Dropbox loads on startup?

3

You can edit your /etc/fstab file to add whichever partition you need. You can find the wiki here.

1
  • 2
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Braiam Aug 25 '13 at 12:15
8

Yeah.

You would need to mount your partition when your system starts.

For detailed guide refer Automatically Mount Partitions in Ubuntu.

If your have external NTFS partition then ntfs-config will ease your task and let you mount all ntfs partitions easily. To install ntfs-config, open terminal and type;

sudo apt-get install ntfs-config
1
  • I am using the most recent loki/elementary (as of this date) and this was the easiest way to get all of my 11 ntfs disks to be ready at boot, including the one that contains my dropbox. Thanks!!! – schmoopy Jul 16 '17 at 20:47
6

I edited the /etc/fstab file.

Step 1. List your partitions by UUID:

sudo blkid

Step 2. Edit /etc/fstab file.

To edit the file directly in terminal, run:

sudo nano -Bw /etc/fstab

Step 3. Insert an extra line in fstab; the line should look like:

UUID="01CE8D75DCC82F80"    /media/G-Drive    ntfs  rw,auto,user,fmask=0111,dmask=0000   0     0

You will have to replace 01CE8D75DCC82F80 with your UUID.

You will have to replace /media/G-Drive with the location where you want to mount.

You might want to change ntfs if your partition is a different type.

If you change ntfs than you might have to change options as well (rw,auto,user,fmask=0111,dmask=0000 gives anybody access to this NTFS partition).

Step 4. Restart and keep fingers crossed, if "Drobox Unlink-ed message" not shown than you have been successful.

2
  • Is there any way to see how the drive is currently mounted so I can properly populate fstab with the same (rw,auto,user,fmask=0111,dmask=0000 options? – timbram Apr 13 '18 at 3:08
  • Looks like the findmnt command may work pretty well! – timbram Apr 13 '18 at 3:18
1

Got this idea from @Thomas Kainrad's comment

You can delay the startup of Dropbox so the drive has time to mount. First you need to disable Dropbox's option to load at startup:

enter image description here

Then add your own startup entry for Dropbox but add the X-GNOME-Autostart-Delay parameter and set it to the number of seconds you'd like to delay.

Save this under ~/.config/autostart/sleepy-dropbox.desktop

[Desktop Entry]
Type=Application
Exec=dropbox start -i
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
X-GNOME-Autostart-Delay=2
Name[en_US]=My Sleepy Dropbox
Name=My Sleepy Dropbox
Comment[en_US]=Custom command for starting dropbox due to drive not being mounted yet
Comment=Custom command for starting dropbox due to drive not being mounted yet
0

Another way of doing this would be using a startup script. This way you could avoid mounting a partition globally if for some reason that's not what you wanna do. This would be a very simple way of doing it:

#!/bin/bash
udisks --mount /dev/<your partition> && dropbox start -i

You will need to make sure to uncheck the "Start Dropbox on system startup" checkbox in your Dropbox prefernces and of course add the startup script as startup application.

0

For some reason I had to tweak @elemer82 answear to make it work with my ext4 partition. I put it here for the record. You may not need the UUID: in my case I just used /dev/sda in my /etc/fstab.

So I just did:

sudo nano -Bw /etc/fstab

And entered the following line (I added the header here for clarity):

# <file system>  <mount point>          <type>  <options>   <dump>  <pass> 
/dev/sda         /media/edelans/data1    ext4    defaults     0       2

You can check the doc of fstap for more details about the options. The defaults options were all I needed for a data partition where I put my dropbox folder. (Note that it's an ext4 partition, only accessed by ubuntu, no windows dualboot here).

0

I just did what @edelans said but it crashed my GUI. I actually had to mix it with @elemer82's solution.

Using sudo blkid allowed be me realize that my HDD was not on /dev/sda but on /dev/sdb1 instead.

I just had to change that in @edelans's solution and everything works. Dropbox and Copy now start normally without error.

0

For a GUI solution: install Disks (aka Gmome Disks):

sudo apt-get install gnome-disk-utility

Even in KDE it brings no supplementary dependencies.

Start Disks, select the partition, then select "Additional partition options" - "Edit mount options".

enter image description here

On the next window uncheck User Session Defaults, check "Mount at system startup" and set the mount point.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.