0

This question already has an answer here:

When I log in to my user account, or guest or any other, I get a black screen and I can see a cursor icon and move it.

But nothing else is on screen, can't run commands with ALT-F2, meta keys don't do anything it seems. I can switch to another console, but the graphical interface does not work.

Even if I create another user account or guest account, it's still the same.

I've installed gnome from terminal (with lightdm though) and it is the same.

What could be the problem here, how can I reset stuff?

I have tried installing gnome, switching to gdm etc.

I have Ubuntu 13.10 installed (about 10 days ago). Didn't do anything funky recently or install new software before the incident, it just got b0rked suddenly.

Update: When I startX from 'nother console, the log says that the stuff is initializing. The last thing done is I see:

Loading extension GLX (II) [KMS] Kernel modesetting enabled. The
XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:           Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                    Ignoring extra symbols 
Errors from xkbcomp are not fatal to the X server

marked as duplicate by Mitch Mar 6 '14 at 12:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Well, no, my computer boots normally. It goes to black screen with cursor after I log in, not after boot. – Zlatko Mar 6 '14 at 10:49
  • After booting , press ctrl + alt + f1 and login from there. After login type startx . It may give you more idea about problem. – g_p Mar 6 '14 at 10:56
  • 1
    That too goes to black screen. Where can I find log files for this thing? Because I can see some lines briefly before it goes black on 'startx' – Zlatko Mar 6 '14 at 10:59
1

I think it's aproblem related to your graphics. There must be some problem during installion of ubuntu.

First try deleting the /etc/X11/xorg.conf and restart your system.

Or you can try reinstall of below listed packages: On startup press:

Ctrl + Alt + F1

Then:

apt-get install --reinstall xorg-xserver*
apt-get install --reinstall gdm
apt-get install --reinstall unity

Same thing happened with me and tried to look for the solution once succeeded but later ended up with a re-install. If you're installing through usb then it is very important to use the correct software to make usb bootable. I have faced this so telling you. I think if you decide to re-install ubuntu then use "unetbootin".

  • I ended up doing reinstall of everything xorg*, xserve*, fglrx* related. – Zlatko Mar 7 '14 at 13:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.