2

I think my Applications Menu (the top right in Gnome Fallback) is broken or something. I was messing around with MenuLibre and after I closed it, an additional "System Tools" menu appeared above Accessories containing a "folder" only containing Synaptic (the menu item I was changing). After closing MenuLibre, Alacarte and MenuLibre no longer open. I've tried apt-get purge menulibre alacarte and re-installing them, but nothing happened.

Does anyone know how to fix my menu so I can edit it? Thanks!

Additional Infomation:

I'm running Ubuntu Trusty 14.04 Development as of 6 March 2014 with Gnome Fallback, and after upgrading to Trusty, my menus have been "reset", ie everything is normal apart from any shortcuts I've added which have been moved to other.

When I open alacarte in terminal I get this:

** (alacarte:32703): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(alacarte:32703): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(alacarte:32703): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
**
ERROR:/build/buildd/gnome-menus-3.10.1/./libmenu/gmenu-tree.c:4022:preprocess_layout_info: assertion failed: (!directory->preprocessed)
Aborted

When I open MenuLibre in terminal I get this:

WARNING:menulibre: getDefaultMenuPrefix() 'No menu prefix found, MenuLibre will not function properly.'
**
ERROR:/build/buildd/gnome-menus-3.10.1/./libmenu/gmenu-tree.c:4022:preprocess_layout_info: assertion failed: (!directory->preprocessed)
Aborted
  • Which os, which version? – Stormvirux Mar 6 '14 at 9:40
  • The lastest development build of Trusty (as of the time of writing, March 6 2014), but it was working fine before I tried messing about with MenuLibre. – Bentley Carr Mar 6 '14 at 9:47
  • 1
    Ok - I've solved it, can I post an answer while it's "on hold" – Bentley Carr Mar 8 '14 at 2:25
  • 2
    @Yharooer I have reopened your question for now. Please post your answer. I'm going to have to close it again afterwards, because site policy makes 14.04 off-topic until it is released however. – Seth Mar 8 '14 at 2:30
  • 1
    A Good question... and a great final answer... This is not off topic, it is a valid question that has affected many. – pst007x Oct 16 '14 at 23:18
6

"I figured it out. All I had to do was remove ~/.config/menus and alacarte and libremenu opened without a problem."

I confirm the solution for menulibre error on Linux Xfce 17.0. I delete the indicated file and everything works normally.

| improve this answer | |
  • This didn't work for me in debian jessie, I still have the assertion failures for alacarte... – user77164 Feb 9 '15 at 6:04
  • Doesn't work for me either. – Philipp Ludwig Aug 26 '18 at 11:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.